2 Replies Latest reply on Feb 3, 2009 3:36 PM by JC Hundy

    Upgrade Hibernate

    JC Hundy Newbie

      Hey guys, awesome product, but I'm having problems trying to integrate it into out existing environment with the latest version of Hibernate. I tried to just replace the proper Hibernate jars, which didn't seem like a big deal, but they conflicted with the jbossall-client.jar in the soap.esb project. What the heck is this silly jar? What is the soap.esb project? Can it be removed?

      Thanks,
      JC

        • 1. Re: Upgrade Hibernate
          Daniel Bevenius Master

          Hi,


          What is the soap.esb project?

          This project contains actions like SOAPClient and SOAPProcessor.

          Can it be removed?

          If you are not using the above mentioned actions then it can be removed.

          Another option might be to scope your .esb archive which is described here:
          http://www.jboss.org/community/docs/DOC-10339

          regards,

          /Daniel

          • 2. Re: Upgrade Hibernate
            JC Hundy Newbie

             

            "beve" wrote:

            Another option might be to scope your .esb archive which is described here:
            http://www.jboss.org/community/docs/DOC-10339


            Ok, this actually worked. Thanks for your help. A word of note to people that do this and use Maven: The Hibernate jars pull in a version of dom4j that won't work with JBoss ESB 4.4 and will cause you pain if you re-scope the .esb archive. You'll need to exclude it like so:

            <dependency>
             <groupId>org.hibernate</groupId>
             <artifactId>hibernate-core</artifactId>
             <version>3.3.1.GA</version>
             <exclusions>
             <exclusion>
             <groupId>dom4j</groupId>
             <artifactId>dom4j</artifactId>
             </exclusion>
             </exclusions>
            </dependency>