7 Replies Latest reply on Feb 9, 2009 7:33 AM by zhu sally

    should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5.0.2

    zhu sally Newbie

      hi,all.
      I am totally new to jboss esb and active BPEL. I want to use the ActiveBPEL BPEL Engine to orchestrate business process flow through JBoss ESB.

      I have download the active bpel quickstarts. But the trouble is from its docs and readmes, I can't get the right version of jboss esb, active bpel and jboss as.

      I just guess should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5.0.2? Thank you very much for the reply.

        • 1. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
          Tom Fennelly Master

          Assuming you're talking about the webservices_bpel quickstart, I'm fairly sure the readme for that says it only runs on JBoss ESB installed on JBoss AS (v4.2.x.GA). It needs the AS because there are some EJBs in there and the ESB Server doesn't have any EJB container.

          Follow the steps in the readme and when you run into trouble, come back.

          • 2. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
            zhu sally Newbie

            hi tfennelly,thank you very much for your reply.
            after install the JBOSSESB, I run the helloworld in the quickstart to test.
            It runs well in standalone mode, but when I run it in .esb,
            I got an

            java.lang.ClassNotFoundException: No ClassLoaders found for: org.jboss.jms.server.destination.QueueService

            I have struggled with it for a while but still cant find the solution. Could anybody please give me some hint? Thank you very much

            • 3. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
              zhu sally Newbie

              The No ClassLoader found for org.jboss.jms.server.destination.QueueService has been solved. I guess it is because the default Jboss-4.2.0.GA goes with JBossMQ, instead of JBoss Messaging.
              So in the base-build.xml I change the
              <!--fileset dir="${basedir}" includes="jbm-queue-service.xml"/-->
              to

              but new problems ocuured:
              23:53:57,453 ERROR [URLDeploymentScanner] Incomplete Deployment listing:
              --- MBeans waiting for other MBeans ---
              ObjectName: jboss.esb:deployment=Quickstart_helloworld.esb
              State: NOTYETINSTALLED
              I Depend On:
              jboss.messaging.destination:service=Queue,name=quickstart_helloworld_Request_esb
              jboss.messaging.destination:service=Queue,name=quickstart_helloworld_Request_gw

              --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
              ObjectName: jboss.messaging.destination:service=Queue,name=quickstart_helloworld_Request_esb
              State: NOTYETINSTALLED
              Depends On Me:
              jboss.esb:deployment=Quickstart_helloworld.esb



              • 4. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
                Tom Fennelly Master

                You shouldn't need to do any of this. Sounds like you're not deploying the Quickstarts properly.

                What version of the ESB are you using? If you're running on anything older than ESB 4.4, please upgrade. Are you sure you're deploying these onto an ESB Server?

                If deployed as per the doc and readmes, the quickstarts should be configured with the correct JMS provider queue definitions for the target Server.

                • 5. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
                  zhu sally Newbie

                  thanks tfennelly.
                  I change to JBOSS AS 4.2.2+ JBOSS ESB 4.4+active bpel 5.0.2
                  the helloworld goes well but when i run the webservice_bpel, I got the error :

                  --- MBeans waiting for other MBeans ---
                  ObjectName: jboss.esb:deployment=Quickstart_webservice_bpel.esb
                  State: FAILED
                  Reason: java.lang.RuntimeException: org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleExceptio
                  n: Unexpected exception while instantiating managed instance
                  I Depend On:
                  jboss.esb:service=SoapUIClientService
                  jboss.esb.quickstart.destination:service=Queue,name=quickstart_webservice_bpel_esb_reply
                  jboss.esb:deployment=jbossesb.esb
                  jboss.esb.quickstart.destination:service=Queue,name=quickstart_webservice_bpel_gw
                  jboss.esb.quickstart.destination:service=Queue,name=quickstart_webservice_bpel_esb
                  jboss.esb:deployment=soap.esb
                  jboss.esb:deployment=smooks.esb

                  --- MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM ---
                  ObjectName: jboss.esb:deployment=Quickstart_webservice_bpel.esb
                  State: FAILED
                  Reason: java.lang.RuntimeException: org.jboss.soa.esb.listeners.lifecycle.ManagedLifecycleExceptio
                  n: Unexpected exception while instantiating managed instance
                  I Depend On:
                  jboss.esb:service=SoapUIClientService
                  jboss.esb.quickstart.destination:service=Queue,name=quickstart_webservice_bpel_esb_reply
                  jboss.esb:deployment=jbossesb.esb
                  jboss.esb.quickstart.destination:service=Queue,name=quickstart_webservice_bpel_gw
                  jboss.esb.quickstart.destination:service=Queue,name=quickstart_webservice_bpel_esb
                  jboss.esb:deployment=soap.esb
                  jboss.esb:deployment=smooks.esb

                  Thank you very much for your hint

                  • 6. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
                    Tom Fennelly Master

                    I'd suspect what you're showing here is as a consequence of an earlier error. Search back up the server log for a deployment error just before this.

                    • 7. Re: should I use JBOSS AS 4.2.0+JBSS ESB 4.2 + active BPEL 5
                      zhu sally Newbie

                      yes,thanks.This problem has been solved, it's because I haven't set a proper value of
                      order.approval.drop.location' property in
                      'webservice_bpel/services/order-manager/order-manager.properties.

                      the webservice_bpel runs very well now. Thank you very much.