3 Replies Latest reply on Feb 27, 2009 7:35 AM by Nick Belaevski

    tree not showing in panelBarItem

    Johan Borchers Newbie

      Hello,

      I'm using RichFaces 3.3.0.GA. I do have a fully functioning tree in a normal panel. The panel above the tree panel is one with search fields.
      I wanted to reduce space used by the search fields. The panelBar seems a good solution. But the tree does not show up in the panelBarItem. The search fields in the panelBarItem above are fine. If I put a text output field as a test above the tree in the same panelBarItem, this object shows up correct but the tree does not.

      Has anyone an idea what may be wrong. Do I forget something? Or is it possible to show a tree in a panelBarItem?

      T.I.A.

      Johan Borchers

        • 1. Re: tree not showing in panelBarItem
          Nick Belaevski Master

          Hi Johan,

          Can you please post screenshot somewhere (e.g. on tinypic)?

          • 2. Re: tree not showing in panelBarItem
            Johan Borchers Newbie

            The picture is of the tree and the search fields in normal panels.
            When I put the tree in a panelBarItem the tree will not show up but the search fields do. Even if I change the order like first the tree and than the search fields nothing helps. It is not a matter of life and death but it would be nice if I could save some space after getting a result in the tree. The search fields would fold up to have some more vertical space for the tree.

            Johan

            http://www.borsoft.nl/jboss/tree.png

            • 3. Re: tree not showing in panelBarItem
              Nick Belaevski Master

              Johan,

              Here is the code I used to test:

              <rich:panelBar width="350" height="400">
               <rich:panelBarItem label="Item 1"></rich:panelBarItem>
               <rich:panelBarItem label="Item 2">
               <rich:tree style="width: 300px;" switchType="ajax" ajaxSubmitSelection="false" nodeSelectListener="#{forum5Bean.processNodeSelection}">
               <rich:recursiveTreeNodesAdaptor roots="#{forum5Bean.rootNodes}" var="item" nodes="#{item.children}">
               <rich:treeNode><h:commandLink styleClass="treeLink" onmousedown="window.treeLink = true;">#{item.locationName}</h:commandLink> - text
               <a4j:support event="onselected" onsubmit="if (window.treeLink) {window.treeLink = false; return true;}"/>
               </rich:treeNode>
               </rich:recursiveTreeNodesAdaptor>
               </rich:tree>
               </rich:panelBarItem>
               </rich:panelBar>
              
              - tree shows up ok. RF 3.3.0.

              Please post full page code that's demonstrating the issue.