0 Replies Latest reply on Apr 15, 2009 6:11 PM by Sidney Zurch

    Error deploying https_2way_ssl quickstart

    Sidney Zurch Novice

      The https_2way_ssl quickstart fails to deploy.

      Using keytool, the password is correct for generated keystore file.

      jbossesb-server-4.5.GA/OS X

      Am I missing something?

      17:44:37,514 INFO [QueueService] Queue[/queue/quickstart_https_2way_ssl_esb_runtest_gw] stopped
      17:44:37,516 WARN [ServiceMessageCounterLifecycleResource] Calling cleanup on existing service message counters for identity ID-12
      17:44:37,640 INFO [JBoss4ESBDeployer] create esb service, quickstart_https_2way_ssl.esb
      17:44:37,682 INFO [QueueService] Queue[/queue/quickstart_https_2way_ssl_esb_runtest_gw] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      17:44:37,752 ERROR [STDERR] java.io.IOException: Keystore was tampered with, or password was incorrect
      17:44:37,752 ERROR [STDERR] at sun.security.provider.JavaKeyStore.engineLoad(JavaKeyStore.java:768)
      17:44:37,752 ERROR [STDERR] at java.security.KeyStore.load(KeyStore.java:1150)
      17:44:37,753 ERROR [STDERR] at org.apache.commons.ssl.KeyStoreBuilder.tryJKS(KeyStoreBuilder.java:438)
      17:44:37,753 ERROR [STDERR] at org.apache.commons.ssl.KeyStoreBuilder.parse(KeyStoreBuilder.java:284)
      17:44:37,753 ERROR [STDERR] at org.apache.commons.ssl.KeyStoreBuilder.build(KeyStoreBuilder.java:88)
      17:44:37,753 ERROR [STDERR] at org.apache.commons.ssl.KeyMaterial.<init>
      ... (I'll spare you).