0 Replies Latest reply on Nov 6, 2009 6:01 PM by Matt Mello

    JBossWS Metro 3.1.1 with ESB 4.6?

    Matt Mello Newbie

      In order that I can use OpenSSO with JBossWS, I have to use Metro (OpenSSO can't work with Native, and I found other issues with CXF).

      However, I notice that the jbossesb-server-4.6 (with the JBossAS 4.2.3 shipped with it) has JBossWS Native installed.

      Has anyone installed JBossWS Metro 3.1.1 into that container?


      I followed the instructions for installing it (which I did successfully according to the ant installer), but when I deploy the Quickstart_webservice_producer.esb, I get the following exception:
      java.lang.IllegalStateException: Cannot obtain ServletAdapter
      at org.jboss.wsf.stack.metro.RequestHandlerImpl.handleHttpRequest(RequestHandlerImpl.java:74)

      Does anyone have any suggestions on getting JBossWS Metro 3.1.1 to work with the ESB 4.6 AS 4.2.3 container?

      Thanks so much for any help!

      -- Matt

      PS: This is sort of a cross-post with the JBossWS forum:
      http://www.jboss.org/index.html?module=bb&op=viewtopic&t=161267