2 Replies Latest reply on Nov 13, 2009 11:57 AM by Rui Aguiar

    Unresponsive EPR using ServiceInvoker from MDB

    Rui Aguiar Newbie

      Hi!
      I'me using this ServiceInvoker to send a message to the ESB from a MDB. Previously this code was inside a WebService and it worked. Now it gets 'Unresponsive EPR'... Why?

      ServiceInvoker invoker2 = new ServiceInvoker("sgp.esb.svc", "sgp.send.message");
      org.jboss.soa.esb.message.Message message2 = MessageFactory.getInstance().getMessage();
      message2.getBody().add("FROM", 2L);
      message2.getBody().add("TO", 3L);
      message2.getBody().add(XML.serialize(serviceMessage));
      org.jboss.soa.esb.message.Message response = invoker2.deliverSync(message2, TIMEOUT_MILLIS);

      And i'me getting 'Unresponsive EPR':
      org.jboss.soa.esb.listeners.message.MessageDeliverException: Failed to deliver message [header: [ ]] to Service [sgp.esb.svc:sgp.send.message]. Told not to retry.




        • 1. Re: Unresponsive EPR using ServiceInvoker from MDB
          Anonymous User Newbie

          Hello.

          Just an idea.

          is your JMS Connection Pool too small ? If yes:

          Increase JMS Connection Pool (default is 20)
          in jbossesb.sar\jbossesb-properties.xml from 20 (default) to 40:



          If it works, this was the cause of your problem.

          Br,

          Dennis

          • 2. Re: Unresponsive EPR using ServiceInvoker from MDB
            Rui Aguiar Newbie

            Thanks, Garuda!
            In our experiences with ESB we've already done that. In fact we had lots of 'Unresponsive EPR's in high load situations. We increased the JMS Connection Pool (actually to a really exagerated value - 1000) and still got some. Then we saw a 'connections' setting in the file you mention. our prolems were solved when we increased that value.

            This problem, however, is of a different kind. Is happens only in this situation, i.e., calling serviceInvoker from the MDB (from a WebService is ok). I'me trying to get some more log. We've had a similar problem with a web bean - the bean transaction somehow locks the esb transaction.

            I've changed the MBean to NOT_SUPPORTED transaction and the problem disapear, now i'm only worried about failed message not going back to the queue since there is no transaction.