11 Replies Latest reply on Feb 12, 2007 3:15 PM by Ryszard Kozmik

    Help with Install...

    Casey Boyd Novice

      JBoss AS 4.0.5
      JBoss Portal 2.4
      JBoss Forum 1.0.0 Beta P2.4

      Put the forum ear in deploy...started up Jboss...logged into the Portal...

      The database tables get created...

      I can see that the Forum Porlet and JSF Forum Porlet got deployed.

      But what do I do from here?

      Do I need to create instances and create a new page with these portlets?

      Am I missing something?

      Thanks

      indy

        • 1. Re: Help with Install...
          Ryszard Kozmik Master

          Hello

          Yes, you have to create an instance of JSFForumsPortlet and place it wherever you want. You can create new page and add it there or replace one of existing windows with this instance. It's your portal.

          Regards
          ----------------------
          Ryszard Kozmik
          JBoss Forums Lead
          JBoss Labs Team

          • 2. Re: Help with Install...
            Casey Boyd Novice

            When I do that, I get a blank page where the Forum Portlet should be....

            • 3. Re: Help with Install...
              Casey Boyd Novice

              I get this...

              
              13:17:36,623 INFO [RendererUtils] Unable to find component 'name' (calling findComponent on component 'portal_form_1:_id153jbp15f0ce3b'). We'll try to return a guessed client-id anyways - this will be a problem if you put the referenced component into a different naming-container. If this is the case, you can always use the full client-id.
              13:17:36,642 INFO [RendererUtils] Unable to find component 'name' (calling findComponent on component 'portal_form_2:_id160jbp15f0ce3b'). We'll try to return a guessed client-id anyways - this will be a problem if you put the referenced component into a different naming-container. If this is the case, you can always use the full client-id.
              13:17:49,919 INFO [RendererUtils] Unable to find component 'name' (calling findComponent on component 'portal_form_1:_id153jbp15f0ce3b'). We'll try to return a guessed client-id anyways - this will be a problem if you put the referenced component into a different naming-container. If this is the case, you can always use the full client-id.
              13:17:49,924 INFO [RendererUtils] Unable to find component 'name' (calling findComponent on component 'portal_form_2:_id160jbp15f0ce3b'). We'll try to return a guessed client-id anyways - this will be a problem if you put the referenced component into a different naming-container. If this is the case, you can always use the full client-id.
              13:17:53,911 INFO [RendererUtils] Unable to find component 'name' (calling findComponent on component 'page_form_4:_id196jbp15f0ce3b'). We'll try to return a guessed client-id anyways - this will be a problem if you put the referenced component into a different naming-container. If this is the case, you can always use the full client-id.
              13:18:21,244 INFO [RendererUtils] Unable to find component 'name' (calling findComponent on component 'page_form_4:_id196jbp15f0ce3b'). We'll try to return a guessed client-id anyways - this will be a problem if you put the referenced component into a different naming-container. If this is the case, you can always use the full client-id.
              
              


              • 4. Re: Help with Install...
                Casey Boyd Novice

                Is there a JSF jar I am missing?

                • 5. Re: Help with Install...
                  Ryszard Kozmik Master

                  You shouldn't need any other libs. JBoss Forums uses libraries from Portal and Tomcat. If you didn't modify/delete any of them, it should be fine. Do you have any exceptions? What database is it?

                  • 6. Re: Help with Install...
                    Casey Boyd Novice

                    No exceptions in log...

                    MySQL is database...

                    I am trying to run JBoss Wiki at the same time.

                    Other then that, everything is standard...

                    I do get this a lot...

                    
                    13:16:13,909 ERROR [STDERR] Feb 12, 2007 1:16:13 PM com.sun.facelets.tag.jsf.ComponentRule warnAttr
                    
                    


                    • 7. Re: Help with Install...
                      Casey Boyd Novice

                      What should I look for in the database?

                      Many tables are in there...

                      1 record in jbp_froums_categories
                      2 records in jbp_forums_forums

                      All the other tables are empty...

                      • 8. Re: Help with Install...
                        Casey Boyd Novice

                        Also...

                        I get this alot...

                        
                        WARNING: /WEB-INF/jsp/management/portlets.xhtml @41,48 border="0" Property 'border' is not on type: org.apache.myfaces.component.html.ext.HtmlGraphicImage
                        
                        
                        


                        • 9. Re: Help with Install...
                          Ryszard Kozmik Master

                          But this one is from Portal's management portlet. Could you please create separate page and place only Forums there?

                          Tables jbp_forums_categories and jbp_forums_forums should contain some example data, this is ok.

                          • 10. Re: Help with Install...
                            Casey Boyd Novice

                            Indy's JBoss Portal Tip of The Day

                            When deploying a Porlet, you can not name it the same thing as the name of the Page you put it on... :)

                            Basically I tried to deploy the Forum Portlet on a page called Forum and it failed..

                            Renamed the Page, everything works fine...

                            Thanks


                            Indy

                            • 11. Re: Help with Install...
                              Ryszard Kozmik Master

                              LOL

                              I would be less surprised if the cause would be space or dot in window/page name. I think it might lead to same problems. But still I'm happy it works for you now.

                              Cheers
                              ----------------------
                              Ryszard Kozmik
                              JBoss Forums Lead
                              JBoss Labs Team