3 Replies Latest reply on Mar 14, 2008 8:18 AM by Andrew Dinn

    JTA transaction records not persisted Correctly

    Dipak Patil Newbie

      I am facing a problem in persisting a transaction in my database
      I am using JMS to perform a transaction using UserTransaction in my Message Driven Bean(MDB),
      I am using JTA one phase commit protocol.
      I am using Ibatis as my ORM
      I am sending a map to be updated to the database,
      I can see the correct values in my DAO and MDB, but in the database the value for first few records in the map are not persisting correctly.
      Please suggest solution.

        • 1. Re: JTA transaction records not persisted Correctly
          Mark Little Master

          OK. And are you using JBoss? This reads like a request for help that would be just as applicable to BEA, Oracle or someone else.

          • 2. Re: JTA transaction records not persisted Correctly
            Dipak Patil Newbie

            i am using jboss-4.2.1 GA
            i am using oracle databse which is on remote server
            i am using the Arjuna transaction api.
            i guess it is transaction dealy problem following are my settings :

            jboss-service.xml:-----
             <mbean code="com.arjuna.ats.jbossatx.jta.TransactionManagerService"
             name="jboss:service=TransactionManager">
             <attribute name="TransactionTimeout">300</attribute>
             </mbean>
            

            we have even tried making the timeout value as 3


            jbossJTA.xml:-------
             <property
             name="com.arjuna.ats.arjuna.coordinator.txReaperTimeout" value="120000"/>
             <!--
             Transaction Reaper Mode, can be: NORMAL or DYNAMIC (default is NORMAL).
             -->
             <property name="com.arjuna.ats.arjuna.coordinator.txReaperMode" value="NORMAL"/>
             <!--
             (default is NO)
             -->
             <property name="com.arjuna.ats.arjuna.coordinator.asyncCommit" value="NO"/>
             <!--
             (default is NO)
             -->
             <property name="com.arjuna.ats.arjuna.coordinator.asyncPrepare" value="NO"/>
            


            we have modified the reaper mode as dynamic,
            we had also tried setting the reaperTimeout value as 0 and 1200000
            we had also tried making asyncCommit and asyncPrepare as true.

            • 3. Re: JTA transaction records not persisted Correctly
              Andrew Dinn Master

               


              i guess it is transaction dealy problem following are my settings :


              You *guess*?

              Is there any reason why you made this guess? Are there messages in the logs which say that the reaper has killed your transaction?

              Perhaps you should try to switch on debug trace so you can be sure to see what is really happening.