1 Reply Latest reply on Sep 25, 2007 4:39 PM by Tom Clifford

    trouble with deploying, running book samples

    Tom Clifford Newbie

      Greetings to all.

      I've set up and tried to deploy the examples from the book, in particular
      chap 04, and get "TravelAgentRemote not bound", as described in a few
      posts to this forum.

      When I deploy the titan.jar file to \jboss\server\all\deploy, I get no
      messages on the jboss console to indicate anything has been deployed.

      My prior experience with JBoss makes me believe that jar files are not
      deployable; I've only ever deployed war or ear files.

      As long as there is an ejb-jar.xml or jboss.xml, I dont' know of any reason
      why jboss should not deploy a jar file, but it is not doing it.

      I've installed JBoss 4.0.4ga, with the jboss-EJB-3.0-RC1 package.
      It told me to install it to the ALL server deploy and lib dirs, so that's
      what I did, brought up JBoss (no errors), and deployed titan.jar,
      but no messages.

      Has anyone run across this or have a suggestion ?

      The one I tried to deploy last is the ex04_3 sample, because it has
      a jboss.xml along with persistance.xml, so I thought JBoss might
      see the beans due to the descriptors in the jboss.xml.

      But no luck.

      If I come across an answer, I'll post it.

      Thanks......tom c.