0 Replies Latest reply on Dec 14, 2009 4:51 PM by mike cann

    JGroup Oddness... GMS?

    mike cann Newbie
      Hi List,

      Only just joined, im not sure if this is the right place to post or not so let me know if it isnt.

      Im trying to use JGroups in a project.

      First things first tried running a very simple example but couldnt get the two machines to talk to each other, i read all the documentation but still couldnt work out why.

      I tried using the webstart demo of the draw (found here http://www.jgroups.org/demos.html) thats actually the replicatedcache demo and to my surprise it worked.

      I downloaded the .jar that the jnlp uses and ran it from the command line and got:


      ---------------------------------------------------------
      GMS: address is 192.168.1.69:54939 (cluster=replcache-cluster)
      ---------------------------------------------------------



      Now when I tried to run the ReplCacheDemo from within the jgroups-all.jar I get the following:



      java -cp jgroups-all.jar org.jgroups.demos.ReplCacheDemo

      14-Dec-2009 20:17:24 org.jgroups.logging.JDKLogImpl info
      INFO: JGroups version: 2.8.0.CR7

      -------------------------------------------------------------------
      GMS: address=M-Win7-38823, cluster=replcache-cluster, physical address=fe80:0:0:
      0:69e5:8edf:3e90:e817:62330
      -------------------------------------------------------------------


      So im not sure whats going on here, it looks like the jnlp demo is using a different GMS (?) settings to the one in jgroups-all.jar, so I tried to take the udp.xml file from the jnlp jar and use it in a simple example and I get the follwing errors:



      14-Dec-2009 21:12:12 org.jgroups.logging.JDKLogImpl info
      INFO: JGroups version: 2.8.0.CR7
      Exception in thread "main" org.jgroups.ChannelException: unable to setup the protocol stack
              at org.jgroups.JChannel.init(JChannel.java:1706)
              at org.jgroups.JChannel.<init>(JChannel.java:243)
              at org.jgroups.JChannel.<init>(JChannel.java:226)
              at jgroupssimple.Main.main(Main.java:25)
      Caused by: java.lang.Exception: unable to load class for protocol  (either as an absolute -  - or relative - org.jgroups.protocols. - package name)!
              at org.jgroups.stack.Configurator$ProtocolConfiguration.createLayer(Configurator.java:1244)
              at org.jgroups.stack.Configurator$ProtocolConfiguration.access$000(Configurator.java:1135)
              at org.jgroups.stack.Configurator.createProtocols(Configurator.java:368)
              at org.jgroups.stack.Configurator.setupProtocolStack(Configurator.java:88)
              at org.jgroups.stack.Configurator.setupProtocolStack(Configurator.java:54)
              at org.jgroups.stack.ProtocolStack.setup(ProtocolStack.java:452)
              at org.jgroups.JChannel.init(JChannel.java:1702)
              ... 3 more
      Java Result: 1
      BUILD SUCCESSFUL (total time: 0 seconds)



      Anyone any clues as to whats going on here?
      Cheers for your time
      Mike