2 Replies Latest reply on Jan 13, 2010 3:55 AM by Byron du Preez

    Integrating Sun Open MQ and JBoss

    Rocky Triton Newbie

      I'm trying the simplest thing, just to add the resource adapter for IMQ to JBoss but I get crazy errors:

       

      org.jboss.deployers.spi.DeploymentException: Error during deploy: vfszip:/C:/src/jboss-5.1.0.GA/server/default/deploy/imqjmsra.rar/
              at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
              at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:177)

      --------

      Caused by: java.lang.IllegalStateException: Expected either '.jar' or '.jar/' at the end of imqjmsra.rar
              at org.jboss.ejb3.deployers.Ejb3ClientDeployer.getDeploymentJndiName(Ejb3ClientDeployer.java:214)

       

      I don't get it, it's complaining that the imqjmsra.rar file should end in .jar?  There are other .rar files in the deploy directory.  I tried renaming it to .jar then it gives me an error that it should be .rar.  Has anyone here tried to integrate these two?

       

       

      Is it preferable to just use JBoss' internal message queueing mechanism? I'm just trying to learn here and I would assume that people would integrate IMQ with an app server like JBoss and not just use an app server's default implementation.

       

      thanks

        • 1. Re: Integrating Sun Open MQ and JBoss
          Yong Hao Gao Master

          Hi,

           

          This is more like a JBoss deployment issue, pls ask the AS guys. Just a wild guess, I think your imqjmsra.rar may have incompatible structure/contents with JBoss. I suggest you pickup an existing rar file, unzip it and compare the contents with your rar, see if there is any difference.

           

          Howard

          • 2. Re: Integrating Sun Open MQ and JBoss
            Byron du Preez Newbie

            To resolve this issue, you need to do the following:

            1. Unzip the standard “imqjmsra.rar” in “<OPEN_MQ_HOME>/mq/lib/” to a temporary folder.
            2. Edit the standard “META-INF/MANIFEST.MF” file in this temporary folder and replace the file’s original contents:
              Manifest-Version: 1.0
              Specification-Title: Open Message Queue / Sun Java(tm) System Message Queue J2EE Resource Adapter for JMS
              Class-Path: imqbroker.jar
              Created-By: 1.5.0_09 (Sun Microsystems Inc.)
              Main-Class: com.sun.messaging.jmq.Version
              Implementation-Title: Open Message Queue
              Specification-Vendor: Sun Microsystems, Inc.
              Specification-Version: 1.5
              Implementation-Version: 4.3 (Build 7-g)
              Implementation-Vendor: Sun Microsystems, Inc.
              Name: com/sun/messaging/jms/ra


              with something like the following:
              Manifest-Version: 1.0
              Created-By: 1.5.0_09 (Sun Microsystems Inc.)
              Sealed: false
              Specification-Title: J2EE Connector Architecture
              Specification-Version: 1.5
              Specification-Vendor: Sun Microsystems, Inc.
            3. Implementation-Title: Open Message Queue J2EE Resource Adapter for JMS
              Implementation-Version: 4.3 (Build 7-g)
              Implementation-Vendor: Sun Microsystems, Inc.

              The “Class-Path”, “Name” and/or “Main-Class” entries in the original file seem to be causing the deployment problem.

              Re-zip the modified contents into a new version of the “imqjmsra.rar” file.
              i
              .      Ensure that you created a ZIP archive and NOT a RAR archive.
              ii.      Ensure that the root of the new “imqjmsra.rar” file contains a META-INF folder and 3 jars.

              Copy the modified “imqjmsra.rar” to “<JBOSS_HOME>/server/<server name [default]>/deploy/”.