3 Replies Latest reply on Jun 6, 2012 4:36 AM by Avor Nadal

    Deployment on jboss 5.1.0 enters in to a infinite undeploy deploy loop

    joshna k Newbie

      When i deploy a app which is working fine on 4.0.5.G.A on jboss 5.1.0.G.A I see the following error

       

      7:32:27,126 INFO [config] Initializing Mojarra (1.2_12-b01-FCS) for context '/admin-console' 17:32:45,678 INFO [TomcatDeployment] undeploy, ctxPath=/admin-console 17:32:58,307 INFO [TomcatDeployment] deploy, ctxPath=/admin-console 17:32:58,589 INFO [config] Initializing Mojarra (1.2_12-b01-FCS) for context '/admin-console' 17:33:17,276 INFO [TomcatDeployment] undeploy, ctxPath=/admin-console 17:33:30,047 INFO [TomcatDeployment] deploy, ctxPath=/admin-console 17:33:30,538 INFO [config] Initializing Mojarra (1.2_12-b01-FCS) for context '/admin-console' 17:33:49,205 INFO [TomcatDeployment] undeploy, ctxPath=/admin-console 17:34:01,963 INFO [TomcatDeployment] deploy, ctxPath=/admin-console 17:34:02,272 INFO [config] Initializing Mojarra (1.2_12-b01-FCS) for context '/admin-console' 17:34:20,834 INFO [TomcatDeployment] undeploy,

       

      I dont have any temp IDE generated files in WEB-INF or META-INF as mentioned in the post http://seamframework.org/Documentation/WhatHappensWhenYouDeploySeamAppInJBoss5

       

      Any help will be appreciated .

        • 1. Re: Deployment on jboss 5.1.0 enters in to a infinite undeploy deploy loop
          jaikiran pai Master

          The "admin-console" shipped by JBoss seems to be going in re-deployment loop. Is this a clean installation of JBoss or did you change anything? Does this happen even if you have not deployed your application? And which version of Java and which operating system are you on?

          • 2. Re: Deployment on jboss 5.1.0 enters in to a infinite undeploy deploy loop
            gpsingh Newbie

            I am still facing this problem. All i did was , copy admin-console.war from default/deploy folder to standard folder and then run JBoss AS 5.1 by executing following cmd. (This was wriiten in Documentation).

             

                   run.bat -c standard

             

            This happens even if there are no applications. I am using java1.6.27 and OS windows 7.

            • 3. Re: Deployment on jboss 5.1.0 enters in to a infinite undeploy deploy loop
              Avor Nadal Newbie

              I'm sorry for updating such an old thread, but yesterday I faced the same error when I tried to secure the JBoss AS 5.1 GA default applications. But I have been able to find the cause (at least in my personal case) and want to share it with other users.

               

              I'm used to make a backup of every configuration file which I edit. So when I was modifying the deployment descriptor of "admin-console.war" I made a copy of "./WEB-INF/web.xml" and left it in such directory. Then, when I started JBoss AS, it started to report about an infinite redeployment of such application. At first, I thought that the deployer detected a file name similar to "web.xml" (the backup file) and it triggered the inifnite re-deployment. But then I renamed it, even left it empty (0 characters), and it still caused the error.

               

              So my conclusion is that this directory, ."/admin-console.war/WEB-INF", must contain the original files only, although you may edit them, of course. Since this application was made with Seam and I've never used it, I don't know if it's an old known bug in this framework or what. Fortunately in JBoss AS 7.1.0 Final we haven't to mess with these things .

               

               

              PD: On Linux it seems that you can add more files there as long as you set them as invisible, naming them with the dot preffix. For example, my backup file is called ".web.xml~20120606" . It's ignored in the deployment.