2 Replies Latest reply on Jan 6, 2010 4:01 AM by Rasa Here

    Run Time Issue In Jboss 4.2.3GA

    Rasa Here Novice

      Hi,

       

      I am using jboss 4.2.3 GA app server and now i am facing a serious problem, but i am not able to find the real issue. Let me explain my issue.

      My application is deployed in jboss and when i takes my app contain jsp page it works fine. Then if i takes web-console or jmx console it gives AbstractMethod error. My application uses an old mvc framework known as SOFIA. If i am using JspServlet of that class then it is not giving any issue. I have tried with a normal jsp page and sofia generated one. Normal jsp pages will give error. But all my servlets are working fine. In my lib file there is no old jsp-api or servlet-api jar files. All are new which i got from JBOSS lib. Now the question is what is the use of client directory in jbos. I have seen that the client contains servlet-api but not jsp-api. How i will find out my issue.

       

       

      Regards

      Rasa.

        • 1. Re: Run Time Issue In Jboss 4.2.3GA
          Rasa Here Novice

          The compilation is happening perfectly for all the jsp's including web-console and Jmx console. No issue for Tomcat console. Hope tomcat console is a servlet hence i guess all the servlets are working fine and only the issue is with JSP's.

           

          See the different jsp;s

          public final class ServerInfo_jsp extends org.apache.jasper.runtime.HttpJspBase
              implements org.apache.jasper.runtime.JspSourceDependent {

          public final class run_jsp extends com.salmonllc.jsp.JspServlet
              implements org.apache.jasper.runtime.JspSourceDependent {

           

          The first one is web-console jsp page and the second is my application jsp pages. The error i am getting for the first one.

           

          See the errors which i am getting,

           

          javax.servlet.ServletException: java.lang.AbstractMethodError: javax.servlet.jsp.JspFactory.getJspApplicationContext(Ljavax/servlet/ServletContext;)Ljavax/servlet/jsp/JspApplicationContext;
               org.apache.jasper.servlet.JspServlet.service(JspServlet.java:273)
               javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
               org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:9

           

          I have checked my application but there is no other servlet-api or jsp-api jars.

          • 2. Re: Run Time Issue In Jboss 4.2.3GA
            Rasa Here Novice
            The issue is solved. Changed the property file of My MVC framework in order to handle the jsp compilation.