1 Reply Latest reply on Jan 11, 2010 6:13 AM by Joram Barrez

    [jBPM 4.3] Database Version Issue between 4.2 and 4.3

    Nils Preusker Newbie

      Hi,

       

      excuse my informal issue posting style... There seems to be an inconsistency with the database upgrade between versions 4.2 and 4.3. Running the database upgrade target of the ant script ("ant -Ddatabase=mysql upgrade.jbpm.schema") will return an error message that the schema is up to date, but running test cases or my application results in this error message:

       

      "jBPM DB schema version (4.2) differs from jBPM library version (4.3): run the upgrade tool first."

       

      The workaround is to set "db.version".VALUE_ to "4.3" manually in the database, but I believe the core of the issue is that the value of "ProcessEngineImpl.JBPM_LIBRARY_VERSION" is still "4.2".

       

      I created a JIRA issue for this: https://jira.jboss.org/jira/browse/JBPM-2718

       

      Cheers,

       

      Nils