2 Replies Latest reply on Jan 7, 2010 7:07 PM by Matthew Dahlman

    Building a VDB - Missing model import to resource ...

    Matthew Dahlman Newbie

      Hi all,

       

      I'm trying to work through the Teiid Designer quickstart. I'm getting further than before thanks to the answers on another thread. But I still have not quite been able to complete this page:

      http://docs.jboss.org/teiid/6.1/quick-start-guide/en-US/html/designer.html

       

      I can get to step 8. But I cannot create the VDB successfully. I can create it. But when I try to save it I get this error:

      Missing model import to resource ../../../../../../../../../../Documents%2520and%2520Settings/mdahlman/My%20Documents/EclipseWorkspace/.metadata/.plugins/org.teiid.designer.vdb.edit/vdbWorkingFolder/1262899659093_3285563913878490630/builtInDataTypes.xsd

       

      It appears to be this problem:

      http://lists.jboss.org/pipermail/teiid-designer-issues/2009-May/000366.html

       

      But that problem was reported in Teiid Designer 6.0 and fixed in 6.1. I'm using 6.2, so in principle I shouldn't be hitting that same problem. Hmm.

       

      Does anyone have suggestions about how I can get past this error? I have already deleted my entire project and re-created it in a different directory that didn't contain spaces. I created my project here: C:\Jaspersoft\EclipseWorkspace. But I find that the following directory still gets created automatically:

      C:\Documents and Settings\mdahlman\My Documents\EclipseWorkspace\.metadata

       

      I guess this is more of an Eclipse setting than a Teiid Designer setting... but I don't know Eclipse well enough to fix it. How can I tell Eclipse not to create this directory here? It seems like it ought to be a preference, but I can't find it.

       

      Thanks,

      Matt