1 Reply Latest reply on Jan 12, 2010 10:03 AM by Ilya Shaikovsky

    Is the ExtendedDataTable's hide/show column buggy?

    Arief Zaki Jumodi Newbie

      Hi,

       

      I'm trying to implement a basic jsf screen using extendedDataTable and i bump to this error when playing around with its livedemo.

      http://livedemo.exadel.com/richfaces-demo/richfaces/extendedDataTable.jsf

       

      The screenshot is as below. To produce this, click the "Time Zone" header's drop-down to display the context menu. Unfortunately, all items were greyed out and some options were displayed on a separate floating frame beneath the table. However, the 2nd & 3rd column works fine.

      Free Image Hosting by FreeImageHosting.net

       

      I tried creating a simple jsp for this and the result is similar but for mine... all columns having the same problem (screenshot as below)

      Free Image Hosting by FreeImageHosting.net

       

      The jsp for my sample is as below (partially copied from the livedemo src code):

       

      <f:view>

          <rich:extendedDataTable

              value="#{layout03TableBean.values}" var="value" id="table" height="400px">

              <rich:column sortable="false" label="Flag">

                  <f:facet name="header"><h:outputText value="Flag" /></f:facet>

                  <h:outputText value="#{value.strCol1}" />

              </rich:column>

              <rich:column sortable="false" width="170px" label="State Name">

                  <f:facet name="header"><h:outputText value="State Name" /></f:facet>

                  <h:outputText value="#{value.strCol2}" />

              </rich:column>

              <rich:column sortable="false" label="State Capital">

                  <f:facet name="header"><h:outputText value="State Capital" /></f:facet>

                  <h:outputText value="#{value.bdCol3}" />

              </rich:column>

          </rich:extendedDataTable>

      </f:view>

       

      My environment is:

      - JBoss AS

      - RF-3.3.2-SR1

      - IE8 & IE7

      - JSF 1.2_11-b01-FCS

       

      Anyone has any workaround or am i doing it correctly here?

      Thanks for any help.