1 Reply Latest reply on Jan 19, 2010 5:50 AM by Max Rydahl Andersen

    How to setup a server and runtime for JBoss AS 6.0.0.M1

    Wouter Hartog Newbie

      I have installed the JBoss AS 6.0.0.M1 server and have the JBoss Tools 3.1 installed on Eclipse Galileo

      I want to use the 6.0.0 environment as a server in Eclipse.

      However, there is no JBoss Community Runtime 6.0 available in the 'New Server Runtime Environment' screen.

      The best I was able to do was to select a 'JBoss 5.1 Runtime' and point to the 6.0.0.M1 installation on my pc.

       

      Is there a better way of doing this?

      What could go wrong if I select the 5.1 Runtime in the wizard and point to the 6.0.0.M1 installation?

      If there's nothing in the Tools 3.1 version for the AS 6 version, in what version is JBoss 6 with all its features supported (e.g. CDI)?

       

      Thank you

        • 1. Re: How to setup a server and runtime for JBoss AS 6.0.0.M1
          Max Rydahl Andersen Master
          What could go wrong if I select the 5.1 Runtime in the wizard and point to the 6.0.0.M1 installation?

          If there's nothing in the Tools 3.1 version for the AS 6 version, in what version is JBoss 6 with all its features supported (e.g. CDI)?

          Nightly build should have an AS 6 adapter but it is technically the same as the AS 5.1 adapter since there aren't really any vital differences between AS 6 M1 and the last AS 5.1 release (yet).

           

          So there is no danger in using AS 5.1 with AS 6.

           

          About CDI then last night build actually includes the first tooling for it - I need to blog it