0 Replies Latest reply on Jan 27, 2010 1:21 PM by karin k

    Increasing tcpListenDrop and Tomcat configuration

    karin k Newbie

      Hi all


      on a heavy used web server (where JBoss 4.2.3.GA with Tomcat 6 is running, on Solaris 10) I observed increasing tcpListenDrop.


      First I observed that the tcp connection parameters was not optimal set, therefore I reset tcp_conn_req_max_q and tcp tcp_conn_req_max_q0


      bash-2.05$ ndd /dev/tcp tcp_conn_req_max_q
      1024 (prior it was 128)


      bash-2.05$ ndd /dev/tcp tcp_conn_req_max_q0
      4096  (prior it was 1024)



      Despite these new tcp settings, tcpListenDrops are still increasing.


      Can anybody give me an advice what I can check on Tomcat side.


      Currently I have checked if the maxThreads of Tomcat's http connector has exceeded
      (by trying to find such a message in our log "All threads are busy" and also by taking a thread dump and looking how many http threads are available).

      Both seems to be ok (I could not find such an error in the log files and the dump does not show http thread count near to the max thread count).

      Any other ideas. Any help is appreciated.