2 Replies Latest reply on Feb 1, 2010 9:39 AM by Michael Eibeck

    Slow performance with JBossWS 3.2.0_GA

    Michael Eibeck Newbie

      Hi,

       

      I use a JBoss AS V5.1.0_GA. I have downloaded JBossWS V3.2.0_GA separately and deployed it to JBossAS V5.1.0_GA.

      I use JDK V1.6.0_17.

       

      I generated a WS from a wsdl with wsconsume using the top down approach. I deployed the server part as a web application (war) on JBoss AS.

       

      The client part is included in a java client.

       

      During testing between client and server I noticed slow response time. I tracked down the problem and noticed, that the slow performance is due to slow response time of the WS stack.

       

      The request time from client to server is OK. The response time of the server response from server to client is up to 21 sec. That's literally the elapsed time from WS server response to WS client reception of this response. I have observed this slow response on all my WS messages, simple ones and complicated ones.

       

      To illustrate the problem I include one message here:

       

      wsdl:

       

        <message name="loginRequest">
        <part name="loginRequestPart" element="sdo:login"/>
      </message>
      <message name="loginResponse">
        <part name="loginResponsePart" element="sdo:loginResponse"/>
      </message>

        <operation name="login">
         <input message="tns:loginRequest"/>
         <output message="tns:loginResponse"/>
         <fault name="LoginFault" message="tns:loginFault"/>
        </operation>

        <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
        <operation name="login">
         <soap:operation/>
         <input>
          <soap:body parts="loginRequestPart" use="literal"/>
         </input>
         <output>
          <soap:body parts="loginResponsePart" use="literal"/>
         </output>
         <fault name="LoginFault">
          <soap:fault name="LoginFault" use="literal"/>
         </fault>
        </operation>

      the involved types of the imported schema file are:

       

      <xs:complexType name="login">
        <xs:sequence>
         <xs:element name="username" type="xs:string"/>
         <xs:element name="password" type="xs:string"/>
         <xs:element ref="sdo:scopeIdentifier"/>
        </xs:sequence>
      </xs:complexType>
      <xs:complexType name="loginResponse">
        <xs:sequence>
         <xs:element name="securityToken" type="xs:hexBinary"/>
         <xs:element name="isSupervisor" type="xs:boolean"/>
         <xs:element name="isEditor" type="xs:boolean"/>
        </xs:sequence>
      </xs:complexType>

       

      Does anyone know what the reason for the slow response time of such a simple WS message could be?

       

      Thanks