0 Replies Latest reply on Feb 9, 2010 2:57 PM by Stan Silvert

    JSFUnit and RichFaces Compatibility

    Stan Silvert Master

      There have been serveral questions lately about problems with RichFaces 3.3.2.SR1.  So I thought I'd address it in a seperate post.

       

      The RichFaces version that JSFUnit 1.1.0 was originally tested with is 3.3.1.GA.  This was also using HtmlUnit 2.5 and Neko 1.9.12.

       

      The JSFUnit test suite for RichFaces does pass with RichFaces 3.3.2.SR1, HtmlUnit 2.7 (just released today), and Neko 1.9.14.  This is using the latest JSFUnit 1.2.0 snapshot available here.

       

      HtmlUnit/Neko has removed several deprecated API calls.  So this makes it difficult to go backward and try older versions of HtmlUnit.  In fact, RichFaces has chosen for now to not support newer versions of HtmlUnit/Neko.  But I'm confident that will have to change soon and we'll all be on the latest version.  If you want to use JSFUnit and RichFaces 3.3.2.SR1 together then you will need to tell RichFaces to use Tidy as its HTML parser instead of Neko.  You do that with a context-param in web.xml:

      <context-param>
         <param-name>org.ajax4jsf.xmlparser.ORDER</param-name>
         <param-value>TIDY,NEKO</param-value>
      </context-param>

       

      Recently, there have been some reports of RichFaces components that don't seem to work with the latest JSFUnit and HtmlUnit/Neko.  I'm sorry I haven't been as responsive to your reports as usual, but illness and other work priorities have put me behind.  I'm trying to get caught up and get everything addressed as quickly as possible.  The best way to ensure your problem will get fixed is to provide sample code that recreates your issue.

       

      Regards,

       

      Stan