1 Reply Latest reply on Feb 18, 2010 1:13 PM by Noa Drach

    MalformedURLException when using xmbean-dd

    Noa Drach Novice

      hello,

       

      I'm using JBOSS 4.2.3.GA

       

      I have a sar inside an ear, so far my sar worked just fine and now I decided to XMbeanize it.

       

      in the MET-INF folder of the SAR I have:

        1. jboss-service.xml
        2. MyService-xmbean.xml

       

      in my jboss-service.xml I changed my mbean entry to look like this :

       

      <mbean code="sample.MyService"
                name="sample:service= MyService"
                xmbean-dd="META-INF/MyService-xmbean.xml">
      </mbean>
      

       

      when I deploy my ear I get the following error:

      Caused by: java.net.MalformedURLException: no protocol: META-INF/MyService-xmbean.xml?

           at java.net.URL.<init>(URL.java:567)

           at java.net.URL.<init>(URL.java:464)

           at java.net.URL.<init>(URL.java:413)

           at org.jboss.system.ServiceCreator.install(ServiceCreator.java:206)

           at org.jboss.system.ServiceConfigurator.internalInstall(ServiceConfigurator.java:451)

           at org.jboss.system.ServiceConfigurator.install(ServiceConfigurator.java:171)

           ... 34 more

       

      any idea what I'm doing wrong?

        • 1. Re: MalformedURLException when using xmbean-dd
          Noa Drach Novice

          So, I found my problem.

           

          I initially thought that the problem lies in the question mark

           

          Caused by: java.net.MalformedURLException: no protocol: META-INF/MyService-xmbean.xml?

           

           

           

           

          and that it probably hide some unwanted characters so I tried pasting the text into notepad and such in order to see these characters and I didn't find anything.

           

          I don't know what I did today that was different than before - but I found it.