3 Replies Latest reply on Aug 3, 2010 8:12 AM by Tim Fox

    Cluster issue

    Christian Longberg Newbie

      Hi, I'm trying to set up a hornetQ stand alone cluster with two nodes but when I start the second node the message below shows up repeatedly on both nodes

       

      [hornetq-discovery-group-thread-dg-group1] 14:42:49,158 WARNING [org.hornetq.core.cluster.impl.DiscoveryGroupImpl]  There seem to be more than one broadcasters on the network broadcasting the same node id

       

       

      Node 1 hornetq-configuration.xml

       

      <configuration xmlns="urn:hornetq"
                     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                     xsi:schemaLocation="urn:hornetq /schema/hornetq-configuration.xsd">
      
         <clustered>true</clustered>
      
         <connectors>      
            <connector name="netty">
               <factory-class>org.hornetq.integration.transports.netty.NettyConnectorFactory</factory-class>
               <param key="host"  value="${hornetq.remoting.netty.host:10.10.48.20}"/>
               <param key="port"  value="${hornetq.remoting.netty.port:5445}"/>
            </connector>
         </connectors>
      
         <acceptors>
            <acceptor name="netty">
               <factory-class>org.hornetq.integration.transports.netty.NettyAcceptorFactory</factory-class>
               <param key="host"  value="${hornetq.remoting.netty.host:10.10.48.20}"/>
               <param key="port"  value="${hornetq.remoting.netty.port:5445}"/>
            </acceptor>
         </acceptors>
      
         <broadcast-groups>
            <broadcast-group name="${broadcast.group.name:bg-group1}">
               <group-address>${broadcast.group.address:231.7.7.7}</group-address>
               <group-port>${broadcast.group.port:9876}</group-port>
               <broadcast-period>5000</broadcast-period>
               <connector-ref connector-name="netty"/>
            </broadcast-group>
         </broadcast-groups>
      
         <discovery-groups>
            <discovery-group name="${discovery.group.name:dg-group1}">
               <group-address>${discovery.group.address:231.7.7.7}</group-address>
               <group-port>${discovery.group.port:9876}</group-port>
               <refresh-timeout>10000</refresh-timeout>
            </discovery-group>
         </discovery-groups>
         
         <cluster-connections>
            <cluster-connection name="${cluster.connection.name:my-cluster}">
               <address>jms</address>      
                 <discovery-group-ref discovery-group-name="${discovery.group.name:dg-group1}"/>
            </cluster-connection>
         </cluster-connections>
         
         <security-settings>
            <security-setting match="#">
               <permission type="createTempQueue" roles="guest"/>
               <permission type="deleteTempQueue" roles="guest"/>
               <permission type="consume" roles="guest"/>
               <permission type="send" roles="guest"/>
            </security-setting>
         </security-settings>
      
         <address-settings>
            <!--default for catch all-->
            <address-setting match="#">
               <dead-letter-address>jms.queue.DLQ</dead-letter-address>
               <expiry-address>jms.queue.ExpiryQueue</expiry-address>
               <redelivery-delay>0</redelivery-delay>
               <max-size-bytes>-1</max-size-bytes>
               <page-size-bytes>10485760</page-size-bytes>         
               <message-counter-history-day-limit>10</message-counter-history-day-limit>
            </address-setting>
         </address-settings>
      
         <paging-directory>${data.dir:../data}/paging</paging-directory>
         <bindings-directory>${data.dir:../data}/bindings</bindings-directory>
         <journal-directory>${data.dir:../data}/journal</journal-directory>
         <large-messages-directory>${data.dir:../data}/large-messages</large-messages-directory>
      
      </configuration>
      

       

      Node 2 hornetq-configuration.xml

       

      <configuration xmlns="urn:hornetq"
                     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                     xsi:schemaLocation="urn:hornetq /schema/hornetq-configuration.xsd">
      
         <clustered>true</clustered>
      
         <connectors>      
            <connector name="netty">
               <factory-class>org.hornetq.integration.transports.netty.NettyConnectorFactory</factory-class>
               <param key="host"  value="${hornetq.remoting.netty.host:10.10.48.21}"/>
               <param key="port"  value="${hornetq.remoting.netty.port:5445}"/>
            </connector>
         </connectors>
      
         <acceptors>
            <acceptor name="netty">
               <factory-class>org.hornetq.integration.transports.netty.NettyAcceptorFactory</factory-class>
               <param key="host"  value="${hornetq.remoting.netty.host:10.10.48.21}"/>
               <param key="port"  value="${hornetq.remoting.netty.port:5445}"/>
            </acceptor>
         </acceptors>
      
         <broadcast-groups>
            <broadcast-group name="${broadcast.group.name:bg-group1}">
               <group-address>${broadcast.group.address:231.7.7.7}</group-address>
               <group-port>${broadcast.group.port:9876}</group-port>
               <broadcast-period>5000</broadcast-period>
               <connector-ref connector-name="netty"/>
            </broadcast-group>
         </broadcast-groups>
      
         <discovery-groups>
            <discovery-group name="${discovery.group.name:dg-group1}">
               <group-address>${discovery.group.address:231.7.7.7}</group-address>
               <group-port>${discovery.group.port:9876}</group-port>
               <refresh-timeout>10000</refresh-timeout>
            </discovery-group>
         </discovery-groups>
         
         <cluster-connections>
            <cluster-connection name="${cluster.connection.name:my-cluster2}">
               <address>jms</address>      
                 <discovery-group-ref discovery-group-name="${discovery.group.name:dg-group1}"/>
            </cluster-connection>
         </cluster-connections>
         
         <security-settings>
            <security-setting match="#">
               <permission type="createTempQueue" roles="guest"/>
               <permission type="deleteTempQueue" roles="guest"/>
               <permission type="consume" roles="guest"/>
               <permission type="send" roles="guest"/>
            </security-setting>
         </security-settings>
      
         <address-settings>
            <!--default for catch all-->
            <address-setting match="#">
               <dead-letter-address>jms.queue.DLQ</dead-letter-address>
               <expiry-address>jms.queue.ExpiryQueue</expiry-address>
               <redelivery-delay>0</redelivery-delay>
               <max-size-bytes>-1</max-size-bytes>
               <page-size-bytes>10485760</page-size-bytes>         
               <message-counter-history-day-limit>10</message-counter-history-day-limit>
            </address-setting>
         </address-settings>
      
         <paging-directory>${data.dir:../data}/paging</paging-directory>
         <bindings-directory>${data.dir:../data}/bindings</bindings-directory>
         <journal-directory>${data.dir:../data}/journal</journal-directory>
         <large-messages-directory>${data.dir:../data}/large-messages</large-messages-directory>
      
      </configuration>