1 Reply Latest reply on Feb 18, 2010 6:52 AM by Thinus Herselman

    Weblogic 8.1 + richfaces 3.1.6

    Thinus Herselman Newbie
      Hi

      I have been developing a small project meant to run under weblogic 8.1. Richfaces according to documentation states that it supports weblogic 8.1.

      Weblogic 8.1 uses servlet specification 2.3 with jsp 1.2 This has been working on my locally installed version of weblogic 8.1 but when deploying to the sparc server, I start running into trouble. I have worked through some of the initial headaches, but then I got an error 500 and couldnt get the details. But after some effort I have come out with this...

       

      javax.servlet.ServletException: javax/servlet/jsp/JspContext
              at weblogic.servlet.internal.RequestDispatcherImpl.forward(RequestDispatcherImpl.java:344)
              at com.sun.faces.context.ExternalContextImpl.dispatch(ExternalContextImpl.java:346)
              at com.sun.faces.application.ViewHandlerImpl.renderView(ViewHandlerImpl.java:152)
              at org.ajax4jsf.application.ViewHandlerWrapper.renderView(ViewHandlerWrapper.java:108)
              at org.ajax4jsf.application.AjaxViewHandler.renderView(AjaxViewHandler.java:216)
              at com.sun.faces.lifecycle.RenderResponsePhase.execute(RenderResponsePhase.java:107)
              at com.sun.faces.lifecycle.LifecycleImpl.phase(LifecycleImpl.java:245)
              at com.sun.faces.lifecycle.LifecycleImpl.render(LifecycleImpl.java:137)
              at javax.faces.webapp.FacesServlet.service(FacesServlet.java:214)
              at weblogic.servlet.internal.ServletStubImpl$ServletInvocationAction.run(ServletStubImpl.java:1072)
              at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:465)
              at weblogic.servlet.internal.TailFilter.doFilter(TailFilter.java:28)
              at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
              at org.ajax4jsf.webapp.BaseXMLFilter.doXmlFilter(BaseXMLFilter.java:141)
              at org.ajax4jsf.webapp.BaseFilter.doFilter(BaseFilter.java:281)
              at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
              at weblogic.servlet.internal.FilterChainImpl.doFilter(FilterChainImpl.java:27)
              at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:6987)
              at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)
              at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:121)
              at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3892)
              at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2766)
              at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:224)
              at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:183)

      JspContext is not part of jsp 1.2 it's newer. I am thinking this exception is originally a ClassNotFoundException or something similar considering the message. There is no 'cause' attached to the exception.

      Following are the jar files contained in my web-application.

      antlr-2.7.6.jar
      asm-1.5.3.jar
      asm-attrs-1.5.3.jar
      cglib-2.1_3.jar
      commons-beanutils-1.6.jar
      commons-collections-3.2.jar
      commons-digester-1.5.jar
      commons-lang-2.4.jar
      commons-logging-1.0.3.jar
      dom4j-1.6.1.jar
      ehcache-1.2.3.jar
      hibernate-3.2.4.sp1.jar
      jsf-api-1.1_02.jar
      jsf-impl-1.1_02.jar
      jstl-1.0.jar
      jta-1.1.jar
      log4j-1.2.15.jar
      richfaces-api-3.1.6.SR1.jar
      richfaces-impl-3.1.6.SR1.jar
      richfaces-ui-3.1.6.SR1.jar
      xercesImpl-2.9.1.jar
      xml-apis-1.3.04.jar

      Do I need to do a custom build the version of richfaces for weblogic? It's obvious that there is a dependency somewhere for jsp2+ but I'm looking for jsp1.2.
      The user guide does specify weblogic 8.1

      Our server is weblogic 8.1 service pack 6. Support jsp 1.2 and servlet 2.3.

      Thank you.