2 Replies Latest reply on Feb 17, 2010 3:25 PM by Tim vB

    GUI demo replicated configuration

    Tim vB Newbie

      Hi,

       

      I'm playing around with the Infinispan GUI demo and i try some different configurations.

      One of the things i want to check out is replication using the GUI demo.

       

      So there is my configuration in XML:

       

      <?xml version="1.0" encoding="UTF-8"?>

       

      <infinispan xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="urn:infinispan:config:4.0">
         <global>
            <transport clusterName="ReplicatedDemoCluster"/>
         </global>

       

         <default>
            <clustering mode="replication">
            <sync/>
            </clustering>
         </default>
      </infinispan>

       

      1) The configuration is loaded via the VM parameter -Dinfinispan.demo.cfg and displayed in the control panel.

      2) I start three instances of the GUI demo all nodes are part of the cluster.

      3) Next 50 random entries are generated and the same entries appear in each node, so far so good.

      4) Now I start a 4th instance of the GUI demo, the new node is successful recognized by all other nodes in the grid.

      The only thing that's wrong in my opinion is that the 4th node don't receive the 50 entries that are present in each of the other nodes.

       

       

      From the FAQ (http://community.jboss.org/wiki/InfinispanTechnicalFAQs):

      replication: if a key exists on one instance, it will also exist on *all* other instances

       

      Maybe i don't understand something or have a mistake in my configuration.

      Hope someone can help me out.


      Cheers Tim