2 Replies Latest reply on Feb 17, 2010 12:26 PM by Saava Kum

    mod_cluster 503 Service Temporary Unavailable errors

    Saava Kum Newbie

      I'm using 1.0.3.GA and set up a tomcat 6 instance and a JBoss5 instance as the backend servers and configured httpd by following the quick-start guide. It appears to me that the 2 nodes are availble for load sharing .. however I get a 503 error after the first attempt. If I hit tomcat & apache alternatively I always get to jboss node and if I don't go to tomcat instance it gives 503. Any help appreciated.

       

      Node Jvm1 is Tomcat 6 instance and Node node01 is Jboss AS5 instance.

       

      This is the manager-console.

       

       

       

       

      Node jvm1 (ajp://127.0.0.1:8009):

      Enable Contexts Disable Contexts
      Balancer: mycluster,Domain: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Elected: 5,Read: 90,Transferred: 0,Connected: 0,Load: 100

      Virtual Host 1:

      Contexts:

      /, Status: ENABLED Disable
      /manager, Status: ENABLED Disable
      /load-demo, Status: ENABLED Disable
      /docs, Status: ENABLED Disable
      /examples, Status: ENABLED Disable
      /host-manager, Status: ENABLED Disable

      Aliases:

      localhost

      Node node01 (ajp://127.0.0.1:8009):

      Enable Contexts Disable Contexts
      Balancer: mycluster,Domain: ,Flushpackets: Off,Flushwait: 10000,Ping: 10000000,Smax: 26,Ttl: 60000000,Elected: 0,Read: 0,Transferred: 0,Connected: 0,Load: 0

      Virtual Host 1:

      Contexts:

      /load-demo, Status: ENABLED Disable

      Aliases:

      localhost