0 Replies Latest reply on Feb 17, 2010 11:10 AM by Matthias gekeler

    LinkageError: loader constraint violation: ......fatalError(Lorg/xml/sax/SAXParseException

    Matthias gekeler Newbie
      Hi

      would   
      like to switch from jboss 3 to jboss4  but i got this  Exception:
      Horrible Exception: java.lang.LinkageError: loader constraint violation:
      when resolving overridden method
      "org.apache.turbine.services.intake.transform.XmlToAppData.fatalError(Lorg/xml/sax/SAXParseException;)V"
      the class loader (instance of org/jboss/mx/loading/UnifiedClassLoader3) of the current class,
      org/apache/turbine/services/intake/transform/XmlToAppData,
      and its superclass loader (instance of <bootloader>),
      have different Class objects for the type org/xml/sax/SAXParseException used in the signature

           at org.apache.turbine.services.intake.TurbineIntakeService.init(TurbineIntakeService.java:201)

      The SaxParserException- class  is in rt.jar from the java-Compiler.
      i can' t see an other class shipped with jboss
      which can introduce this conflict.  I tried java 5  and java 6, there is nearly the same error.