0 Replies Latest reply on Feb 17, 2010 3:50 PM by Andrew Subichev

    JBoss 5.0.0.GA and JasperException

    Andrew Subichev Newbie

      Hi,

      I've moved my app. from Tomcat 5.0.28 to JBoss 5.0.0.GA.  I know this is not the latest JBoss's version, but it is required version by our client.  When I started ap., I noticed JasperException: Unable to compile class for JSP An error occurred at line: 48 in the jsp file:


      /beans/connector-shopping/jsp/shopping_step4soa.jsp
      The operator + is undefined for the argument type(s) java.lang.Object,
      java.lang.Object
      45:      <c:choose>
      46:           <c:when test='${sessionScope["epi:session:ben_pkg_choice"] == "All"}'>
      47:                <c:forEach items='${sessionScope["epi:session:available_tiers"]}'
      var="tierName" varStatus="tierStatus">
      48:                     <c:set var="benPkgSelect" value="${benPkgSelect}${tierName}"/>
      49:                     <c:if test="${not tierStatus.last}">
      50:                          <c:set var="benPkgSelect" value="${benPkgSelect}|"/>
      51:                     </c:if>

       

      in the JSPs that were previously compiling fine.

      I found this article --> https://issues.apache.org/bugzilla/show_bug.cgi?id=46381  saying the reason is Tomcat 6.0.x bug.  They fixed it in later versions of Tomcat.

      Now my question:  is there any way to stay with JBOSS 5.0.0.GA but replace Tomcat that it is using with newer one?  What are the consiquenses of doing that?  Remember, I have to stay in 5.0.0; otherwise, it will become unsupported.

      Thanks in advance.