1 Reply Latest reply on Feb 22, 2010 10:50 AM by Peter Johnson

    Problem moving to 5.1.0 from 4.2.1

    Dominic Hanlan Newbie

      I Have been using JBoss 4.2.1 for about 18months with great success but have recently had the need to upgrade to 5.1.0. Everything went quite well untill I came to upgrade the messaging. I currently have a mixture of Topics and Queues defined. The Queues are used for MDB's and the Topics are used for a set of remote clients to subscribe to.

       

      Having read various documents I got the server started and the destinations registered, the startup log is below.

       

      07:31:49,437 INFO  [ServerPeer] JBoss Messaging 1.4.3.GA server [0] started


      07:58:37,531 INFO  [QueueService] Queue[/queue/MyTest2Queue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,546 INFO  [QueueService] Queue[/queue/reminderEmailQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,562 INFO  [QueueService] Queue[/queue/recallEmailQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,578 INFO  [QueueService] Queue[/queue/reminderSMSQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,593 INFO  [QueueService] Queue[/queue/recallSMSQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,609 INFO  [QueueService] Queue[/queue/ooPrintQueue] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,625 INFO  [TopicService] Topic[/topic/MyTest2Topic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,640 INFO  [TopicService] Topic[/topic/UserTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,656 INFO  [TopicService] Topic[/topic/PatientTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,671 INFO  [TopicService] Topic[/topic/AppointmentTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,687 INFO  [TopicService] Topic[/topic/TreatmentPlanTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,703 INFO  [TopicService] Topic[/topic/AddTPToDiaryTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,734 INFO  [TopicService] Topic[/topic/ChartTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,750 INFO  [TopicService] Topic[/topic/RotaRuleTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,765 INFO  [TopicService] Topic[/topic/MedNoteTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,781 INFO  [TopicService] Topic[/topic/GenNoteTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,796 INFO  [TopicService] Topic[/topic/InvoiceTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:58:37,812 INFO  [TopicService] Topic[/topic/UpdatesTopic] started, fullSize=200000, pageSize=2000, downCacheSize=2000
      07:59:40,453 WARN  [SimpleConnectionManager] A problem has been detected with the connection to remote client 5c4o1r1-ncsk79-g5yyf026-1
      -g5yyf4xj-8, jmsClientID=f-rf5fyy5g-1-620fyy5g-97kscn-1r1o4c5. It is possible the client has exited without closing its connection(s) o
      r the network has failed. All associated connection resources will be cleaned up.

       

      The code which accesses the Topics is unchanged, save the JNDI name of the unclustered connection "ConnectionFactory". Now when ever a message is published, the code executes with out exception but no message are received by the client consumers.

       

      The last line of the listing above shows what happens following exiting the client, indicating that a connection has been made.

       

      The MDB are not receiving any messages either, so there is a general failure in the messaging.

       

      An example of the destination-service.xml for one of the Topics is below,

       

      <mbean code="org.jboss.jms.server.destination.TopicService" name="jboss.messaging.destination:service=Topic,name=MyTest2Topic"
            xmbean-dd="xmdesc/Topic-xmbean.xml">
            <depends optional-attribute-name="ServerPeer">jboss.messaging:service=ServerPeer</depends>
      </mbean>

       

      Any hints on how I would go about solving this one would be great, I have turned on the logging for messaging to DEBUG level but I get nothing when a message is sent, just during startup.

       

      Thanks in advance

       

      /Dominic