2 Replies Latest reply on Mar 2, 2010 10:48 AM by Thomas Heute

    Maven Pom Error in version 3.0.0-CR01

    luca preziati Newbie

      Hi everyone.

      I have just installed gateIn source in my eclipse. I found this eror in maven pom:

       

      [INFO] Scanning for projects...
      [ERROR] The build could not read 1 project -> [Help 1]
      [ERROR]   The project org.exoplatform.portal:exo.portal.parent:3.0.0-CR01 (C:\sviluppo\GateIn\GateIn-3.0.0-CR01\pom.xml) has 3 errors
      [ERROR]     'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.exoplatform.kernel:exo.kernel.commons:jar -> duplicate declaration of version ${org.exoplatform.kernel.version}
      [ERROR]     'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: org.exoplatform.core:exo.core.component.organization.api:jar -> duplicate declaration of version ${org.exoplatform.core.version}
      [ERROR]     'dependencyManagement.dependencies.dependency.(groupId:artifactId:type:classifier)' must be unique: junit:junit:jar -> duplicate declaration of version 3.8.1
      [ERROR]
      [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR]
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/ProjectBuildingException

       

       

      Does anybody have any suggestion? Maven pom is broken?