3 Replies Latest reply on Mar 2, 2010 11:14 PM by cheng wei

    application deployment problem on jboss-5.1.0.GA

    cheng wei Newbie

      Dear all,

       

      I am working on an application(spring + flex). it is working fine on both spring tc server and apache tomcat 6.0.24. When i deploy it into jboss-5.1.0.GA with default settings, it stops booting at the following step:

       

      <code>

      2010-03-01 14:07:02,359 INFO  [org.hibernate.tool.hbm2ddl.SchemaUpdate] (main) schema update complete
      2010-03-01 14:07:02,859 INFO  [STDOUT] (main) 2010-03-01 14:07:02,859 INFO  [main] org.springframework.security.access.intercept.AbstractSecurityInterceptor (AbstractSecurityInterceptor.java:156) - Validated configuration attributes
      2010-03-01 14:07:03,437 INFO  [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/Mars]] (main) Initializing Spring FrameworkServlet 'flex'
      2010-03-01 14:07:05,906 INFO  [STDOUT] (main) 2010-03-01 14:07:05,828 INFO  [main] org.springframework.flex.config.FlexConfigurationManager$ResourceResolverAdapter (FlexConfigurationManager.java:184) - Loading Flex services configuration from: ServletContext resource [/WEB-INF/flex/services-config.xml]

      </code>

       

      i looked through the log file. The only problem i could find was log4j conflicts, so i removed log4j and common-logging. However, it became worse. This time it boot until

       

      <code>

      2010-03-01 14:55:18,546 INFO  [org.jboss.web.tomcat.service.deployers.TomcatDeployment] (main) deploy, ctxPath=/Mars
      2010-03-01 14:55:19,015 INFO  [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/Mars]] (main) Set web app root system property: 'mars.root' = [D:\jboss-5.1.0.GA\server\default\deploy\Mars.war\]
      2010-03-01 14:55:19,015 INFO  [org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/Mars]] (main) Initializing log4j from [classpath:META-INF/spring/log4j.xml]

      </code>

       

      There is no error information i can find in the log. I took a screenshot of jars i used in my project and attached it.

       

      Thanks in advance.

      Cheng

        • 1. Re: application deployment problem on jboss-5.1.0.GA
          cheng wei Newbie

          No body have an idea what the cause is? As there is not any useful log i can find, i don't know how to solve the problem. I am sure the problem must be related to jar conflicts on jboss.

           

          Thanks in advance,

          Cheng

          • 2. Re: application deployment problem on jboss-5.1.0.GA
            jaikiran pai Master

            Are you sure it "stops booting"? Maybe it's just a case of the log messages being no longer written to the CONSOLE (or the log file). Are you able to access http://localhost:8080/

            • 3. Re: application deployment problem on jboss-5.1.0.GA
              cheng wei Newbie

              Thanks jaikiran,

               

              I have tried both with log4j and common-logging jars and without them. When i tried to visit by http://localhost:8080, it kept loading but no page loaded for both cases. When without log4j and common-logging jars, I cannot stop it by CTRL+C. I guess it is dead. However, with log4j and common-logging jars, when i pressed CTRL+C, it reacted and output the following:

               

              resource [/WEB-INF/flex/services-config.xml]
              09:39:49,937 INFO  [ServerImpl] Runtime shutdown hook called, forceHalt: true
              09:39:50,015 WARN  [ProfileServiceBootstrap] Error deactivating profile: Profile
              Key@d8326d[domain=default, server=default, name=default]
              org.jboss.profileservice.spi.NoSuchProfileException: No active profile for: Prof
              ileKey@d8326d[domain=default, server=default, name=default]
                      at org.jboss.system.server.profileservice.repository.AbstractProfileServ
              ice.deactivateProfile(AbstractProfileService.java:391)
                      at org.jboss.system.server.profileservice.ProfileServiceBootstrap.shutdo
              wn(ProfileServiceBootstrap.java:327)
                      at org.jboss.bootstrap.AbstractServerImpl.shutdownServer(AbstractServerI
              mpl.java:571)
                      at org.jboss.bootstrap.AbstractServerImpl$ShutdownHook.run(AbstractServe
              rImpl.java:909)
              09:39:52,046 INFO  [TomcatDeployment] undeploy, ctxPath=/web-console

               

               

              I tried another approach, to add a jboss-web.xml to WEB-INF, but the following error still remained there:

               

              11:44:47,890 ERROR [STDERR] log4j:ERROR A "org.jboss.logging.appender.FileAppend
              er" object is not assignable to a "org.apache.log4j.Appender" variable.
              11:44:47,890 ERROR [STDERR] log4j:ERROR The class "org.apache.log4j.Appender" wa
              s loaded by
              11:44:47,890 ERROR [STDERR] log4j:ERROR [BaseClassLoader@18d3fca{vfsfile:/D:/jbo
              ss-5.1.0.GA/server/default/deploy/Mars.war/}] whereas object of type
              11:44:47,890 ERROR [STDERR] log4j:ERROR "org.jboss.logging.appender.FileAppender
              " was loaded by [org.jboss.bootstrap.NoAnnotationURLClassLoader@291aff].
              11:44:47,890 ERROR [STDERR] log4j:ERROR Could not instantiate appender named "FI
              LE".

               

               

              jboss-web.xml

               

              <!DOCTYPE jboss-web PUBLIC "-//JBoss//DTD Web Application 5.0//EN" 
                  "http://www.jboss.org/j2ee/dtd/jboss-web_5_0.dtd"> 
              <jboss-web>
                  <class-loading>
                      <loader-repository>
                          com.example:archive=unique-archive-name
                          <loader-repository-config> 
                              java2ParentDelegaton=false 
                          </loader-repository-config> 
                      </loader-repository>
                  </class-loading>
              </jboss-web>

               

               

              Thanks in advance,

              Cheng