1 Reply Latest reply on Mar 3, 2010 4:33 PM by Rand Asin

    RichFaces Startup with incomplete page.

    Rand Asin Novice

      I am evaluating RichFaces.  Following http://docs.jboss.org/richfaces/latest_3_3_X/en/devguide/html/GettingStarted.html, I setup the Greeter project and deployed to JBoss 4.2.3 GA, but when I hit the index page, I get a blank page with incomplete HTML.

       

      <!doctype html public "-//w3c//dtd html 4.0 transitional//en">



      <!-- RichFaces tag library declaration -->



      <html xmlns="http://www.w3.org/1999/xhtml">
           <head>
                <title>RichFaces Greeter</title>
           <link class="component" href="/RichFacesDemo/a4j/s/3_3_2.SR1org/richfaces/renderkit/html/css/basic_both.xcss/DATB/eAF7sqpgb-jyGdIAFrMEaw__.faces" rel="stylesheet" type="text/css" /><link class="component" href="/RichFacesDemo/a4j/s/3_3_2.SR1org/richfaces/renderkit/html/css/extended_both.xcss/DATB/eAF7sqpgb-jyGdIAFrMEaw__.faces" media="rich-extended-skinning" rel="stylesheet" type="text/css" /><script src="/RichFacesDemo/a4j/g/3_3_2.SR1org.ajax4jsf.javascript.AjaxScript.faces" type="text/javascript"></script><script src="/RichFacesDemo/a4j/g/3_3_2.SR1org/ajax4jsf/javascript/scripts/form.js.faces" type="text/javascript"></script><link class="component" href="/RichFacesDemo/a4j/s/3_3_2.SR1css/panel.xcss/DATB/eAF7sqpgb-jyGdIAFrMEaw__.faces" rel="stylesheet" type="text/css" /><script type="text/javascript">window.RICH_FACES_EXTENDED_SKINNING_ON=true;</script><script src="/RichFacesDemo/a4j/g/3_3_2.SR1org/richfaces/renderkit/html/scripts/skinning.js.faces" type="text/javascript"></script>

       


      Note the html is missing body tag and doesn't close properly.

      There are no server errors.  Nothing for me to debug.  Does anyone know what I might be doing wrong?  Thanks.