2 Replies Latest reply on Mar 8, 2010 6:42 PM by Stephen Kwan

    JBoss AS crashing

    Stephen Kwan Newbie



      We have a Java web service running in the JBoss application server on Red Hat Enterprise Linux. This works perfectly fine when we first start it up, however after several hundred requests (and sometimes less) the AS crashes with the following:


      run.sh: line 300: 5716 Aborted "$JAVA" $JAVA_OPTS -Djava.endorsed.dirs="$JBOSS_ENDORSED_DIRS" -classpath "$JBOSS_CLASSPATH" org.jboss.Main "$@"


      This is the first time I've ever used JBoss and initial thoughts were we may have been doing something fundamentally wrong with our installation. But we've tried several installations including JBoss EAP(trial),and 5.0.0 jdk6 package and also different Linux installs like OpenSUSE and different hardware to eliminate these as a possible causes!. All with the same result (although in EAP the server doesn't crash but just hangs)


      We now suspect the web service (code as attached), although it is very simple - just instantiates the return object once and then returns the same object for every subsequent request.


      Any comments will be much appreciated, as we are very new to this.






      Details of our environment:


      JBoss Version
      Version: 5.0.0.CR2 (build: SVNTag=JBoss_5_0_0_CR2 date=200809171140)

      Base Location: file:/opt/jboss5/server/
      Base Location (local): /opt/jboss5/server
      Running config: 'default'

      JVM - Hardware
      #CPU: 2

      OS: Linux 2.6.18-164.el5PAE (i386)
      JVM Environment
      Free Memory: 85 MB
      Max Memory: 455 MB
      Total Memory: 282 MB

      #Threads: 68

      JVM Version: 16.0-b13 (Sun Microsystems Inc.)
      JVM Name: Java HotSpot(TM) Server VM