2 Replies Latest reply on Mar 9, 2010 10:19 AM by gift sam

    Rich Page themes problem in Internet Explorer

    gift sam Newbie

      Hi,

       

          I had implemented Richfaces theme using the latest jar files(3.3.2.SR1) for my JSF application. It works fine in firefox and chrome. But in Internet explorer, the components used in the pages are not rendering properly after an ajax action. Also while the application runs in the Internet Explorer, I am getting the browser script error "Object Doesnt support this property or method". Kindly give some valuable inputs to resolve this issue.

       

      Thanks in Advance!!

        • 1. Re: Rich Page themes problem in Internet Explorer
          Ilya Shaikovsky Master
          It's seems works fine at rf-demo. And anyway I guess that js error probably not related actually to themes but just some your cusom event handler failed after ajax request. So show the code please.
          • 2. Re: Rich Page themes problem in Internet Explorer
            gift sam Newbie

            Hi Ilya Shaikovsky,

            Thank you for your immediate reverse. Actually the application works fine in all the browsers before implemeting the rich faces theme. i am having a layoutMain.jsp, where I had implemented a header, Side bar, content and footer. In the side bar, I am using the panel menu component to hold the links. When the user clicks the link in the panel menu, the page will be displayed(included using a4j:include:) dynamically in the content section. Here is my sample layoutMain.jsp for your reference.

             

            layoutMain.jsp

             

            <%@page contentType="text/html" pageEncoding="UTF-8"%>
            
            <%@taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
            <%@taglib prefix="h" uri="http://java.sun.com/jsf/html"%>
            <%@ taglib uri="http://richfaces.org/a4j" prefix="a4j"%>
            <%@ taglib uri="http://richfaces.org/rich" prefix="rich"%>
            
            <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
                "http://www.w3.org/TR/html4/loose.dtd">
            
            <%--
                This file is an entry point for JavaServer Faces application.
            --%>
            <f:view>
                <html>
                    <head>
                        <meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
                        <title>JSP Page</title>
                    </head>
                    <body>
            
                        <rich:page width="1024" theme="smooth" sidebarPosition="left" sidebarWidth="300">
                            <f:facet name="header">
                                <h:outputText value="Sample header"/>
                            </f:facet>
                            <f:facet name="sidebar">
            
                                <a4j:include viewId="/sidebar.jsp"/>
                            </f:facet>
                            
                            <rich:layout>
                                <rich:layoutPanel position="center" width="70*">
            
                                    <a4j:include viewId="#{SampleBean.content}"/>
            
                                </rich:layoutPanel>
                            </rich:layout>
            
                            <f:facet name="footer">
                                <h:outputText value="Sample footer"/>
                            </f:facet>
                        </rich:page>
                    </body>
                </html>
            </f:view>
            
            

            Each page dynamically included in the content section has seperate h:form. No problem while including the pages dynamically. But the problem occurs only when an action performed in the included page of the content section (for eg, Problem occuring in rich faces calender, rich combobox, those components are not displaying after an ajax action). This occurs only in Internet Explorer. But the application works fine in firefox and chrome browsers. Also while the application runs in the Internet Explorer, I am getting the browser script errors like  “Object Doesnt support this property or method”, "object.getElementId is null".  Kindly give some valuable inputs to resolve this issue.

             

            Thanks in Advance!!