0 Replies Latest reply on Mar 9, 2010 7:46 AM by Jannis Wienert

    Add new WAR failes

    Jannis Wienert Newbie

      Hello Forum,


      we encounter a problem with our installations of embedded jopr.


      When we Add a new WAR File, we get a Timeout like this:


      Failed to create Resource ourressource.war - cause: org.rhq.core.pc.inventory.TimeoutException: Call to org.rhq.plugins.jbossas.JBossASServerComponent.createResource() with args [[CreateResourceReport: ResourceType=[ResourceType[id=0, category=Service, name=Web Application (WAR), plugin=JBossAS]], ResourceKey=[null]]] timed out. at org.rhq.core.pc.inventory.ResourceContainer$ResourceComponentInvocationHandler.invokeInNewThreadWithLock(ResourceContainer.java:428) at org.rhq.core.pc.inventory.ResourceContainer$ResourceComponentInvocationHandler.invoke(ResourceContainer.java:381) at $Proxy129.createResource(Unknown Source) at org.rhq.core.pc.inventory.CreateResourceRunner.call(CreateResourceRunner.java:113) at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303) at java.util.concurrent.FutureTask.run(FutureTask.java:138) at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) at java.lang.Thread.run(Thread.java:619)


      I searched all the Jiras of embedded jopr but couldnt find a clue why this error occurs.


      We use JBoss 4.3-EAP on a Solaris 10 shared zone. I also tried it with Jboss 4.2.2.GA and the two JBoss Versions on Windows, always the same pb. We use embedded jopr in Version 1.1, but i also tried out 1.0 and 1.2-RC.


      Can someone give us a hint how to find the problem? Where can we raise the mentioned timeout? Could it be possible that the war- file is the problem?


      Thanks for your feedback.