2 Replies Latest reply on Mar 29, 2010 9:31 PM by Brad Warren

    Tunnelling JBoss 5 over HTTP (80)

    Matt Bowden Newbie

      Hi All,

       

      Firstly I warn you, I am a complete n00b when it comes to JBoss so go easy please....

       

      OK, So the problem I have is I guess in the title; I am trying to Tunnel all traffic to/from JBoss 5 over port 80 to get around firewall restrictions. Previously when I have done this in the past with JBoss 4.x.x I have done the following:

       

      1) Changed the Invoker type below to be http in the standardjboss.xml

                <invoker-mbean>jboss:service=invoker,type=jrmp</invoker-mbean>

       

      2)      Commented out the below in /deploy/http-invoker.sar/META-INF/jboss-service.xml

           <!--  
                <attribute name="InvokerURLPrefix">
      http://</attribute>
                <attribute name="InvokerURLSuffix">:8080/invoker/EJBInvokerServlet</attribute>
                <attribute name="UseHostName">true</attribute>
           -->

           And then added <attribute name="InvokerURL">http://<hostname>:<port>/invoker/EJBInvokerServlet</attribute> instead.     

       

      3)      I would also change the Application.jnlp file so that the following are set:

       

             <property name="clientConfigRoot" value="http://$SERVER$:80"/>
             <property name="java.naming.provider.url" value="http://$SERVER$:80/invoker/JNDIFactory"/>
             <property name="java.naming.factory.initial" value="org.jboss.naming.HttpNamingContextFactory"/>

       

      as opposed to the non tunnelled version of:

       

             <property name="clientConfigRoot" value="http://$SERVER$:80"/>
             <property name="java.naming.provider.url" value="jnp://$SERVER$:1099"/>
             <property name="java.naming.factory.initial" value="org.jnp.interfaces.NamingContextFactory"/>

       

      However, it appears that in JBoss 5 there is a new concept of a unified invoker meaning that point 1 can’t/shouldn’t be changed??? Also if I change the jnlp file so that it matches the above settings it is not recognised and I get a connection refused message when the client tries to initialise.

       

      Iam I missing something obvious here? Are there some other settings that I need to consider change?

       

      Anyway, Thanks for reading.

       

      Kind Regards,

       

      Matt