0 Replies Latest reply on Mar 24, 2010 6:17 PM by Jorge Montero

    AS 4.3.1 to 6.0.0 M2 WS Migration problem

    Jorge Montero Newbie

      I am migrating an EJB3 app from JBoss 4.3.1 to 6.0.0. On deployment of an ejb3 bean, I get the following:

       

      Caused by: javax.xml.ws.WebServiceException: @XmlType missing from fault bean: com.knights.camelot.generalreporting.ejbs.jaxws.ExceptionBean

              at org.jboss.ws.metadata.umdm.FaultMetaData.initializeFaultBean(FaultMetaData.java:255)
              at org.jboss.ws.metadata.umdm.FaultMetaData.eagerInitialize(FaultMetaData.java:225)
              at org.jboss.ws.metadata.umdm.OperationMetaData.eagerInitialize(OperationMetaData.java:469)
              at org.jboss.ws.metadata.umdm.EndpointMetaData.eagerInitializeOperations(EndpointMetaData.java:564)
              at org.jboss.ws.metadata.umdm.EndpointMetaData.initializeInternal(EndpointMetaData.java:548)
              at org.jboss.ws.metadata.umdm.EndpointMetaData.eagerInitialize(EndpointMetaData.java:538)
              at org.jboss.ws.metadata.umdm.ServiceMetaData.eagerInitialize(ServiceMetaData.java:433)

       

      Based on the code in generalreporting.ejbs, the problem is that there is a webService that throws Exception:

       

      void addPOSummaryData(@WebParam(name = "date")Date date,@WebParam(name = "summaryData")List<PendingPOSummary> rows) throws Exception;

       

      In the version of JbossWebServices/EJB3 that 4.3.1 comes with by default, this was deploying and generating a WSDL with no problems at all:

       

       <message name='Exception'>
        <part element='tns:Exception' name='Exception'></part>
       </message>
      .......
      <binding name='PendingPOSummaryWSBeanBinding' type='tns:PendingPOSummaryWSBean'>
        <soap:binding style='document' transport='http://schemas.xmlsoap.org/soap/http'/>
        <operation name='addPOSummaryData'>
         <soap:operation soapAction=''/>
         <input>
          <soap:body use='literal'/>
         </input>
         <output>
          <soap:body use='literal'/>
         </output>
         <fault name='Exception'>
          <soap:fault name='Exception' use='literal'/>
         </fault>
        </operation>
      </binding>

      Is the fact the latest version is not deploying such an ejb3 web service correctly a bug or a feature?