1 Reply Latest reply on Apr 6, 2010 2:24 PM by Max Rydahl Andersen

    How do I know which plugins to upgrade?

    Arbi Sookazian Master

      I'm trying to upgrade from JBT 3.1.0.-M4 to the latest.  The problem is that JBT consists of many plugins.  It would be easier if all the names started with "JBoss Tools", for example, Hibernate Tools is part of JBT but that may not be obvious.  So I selected anything that I think may be related to JBT.  But I'm keeping my existing version of m2e due to this bug in 0.10.0: https://issues.sonatype.org/browse/MNGECLIPSE-2155

       

      It would be nice to be able to revert updates (I just figured that one out: Eclipse Installation details --> select previous configuration --> click revert button)  Cool.

       

      JBT plugins are now all 3.1.0.GA!

       

      available_updates.GIF

        • 1. Re: How do I know which plugins to upgrade?
          Max Rydahl Andersen Master

          Upating to/from Milestones aren't really supported - its just luck if it works

           

          Note, there is no real god way to do what you want to do unless we get an "Uber" feature that includes all plugins, but then it will be harder to actually install subparts.

           

          And we do try and put the same name prefix on our plugin/features but we can't do that for *all* projects for legacy or actually different naming reasons.