1 Reply Latest reply on Mar 31, 2010 7:21 PM by Mike M

    Jbpm service on jboss

    Mike M Newbie

      The dev guide mentions:

       

      14:12:09,301 INFO  [JBPMService] jBPM 4 - Integration JBoss 4
      14:12:09,301 INFO  [JBPMService] 4.0.0.Beta1
      14:12:09,301 INFO  [JBPMService] ProcessEngine bound to: java:/ProcessEngine

       

      These messages do not show up for me when starting up jboss (5.0.0.GA), even though I have deployed jbpm using the ant script, as per the instructions on the user guide. I've checked it out, and everything seems to be deployed correctly in the server.

       

      When trying to troubleshoot, I noticed that the string "bound to" doesn't appear anywhere in any of the jbpm source code. Nor is there any such class "JBPMService". The closest match, org.jbpm.jboss.internal.JbpmService, doesn't bind anything to JNDI.

       

      Any idea what I might be missing?

        • 1. Re: Jbpm service on jboss
          Mike M Newbie

          Never mind. Looks like they changed things a bit. In 4.3, it is now:

           

          17:03:27,872 DEBUG [JbpmService] JbpmService starting...
          17:03:28,498 DEBUG [ProcessEngineImpl] jndi name java:/ProcessEngine is not bound
          17:03:28,498 DEBUG [WireContext] eagerly initializing org.jbpm.pvm.internal.id.DatabaseIdComposer
          17:03:28,498 DEBUG [WireContext] eagerly initializing org.jbpm.pvm.internal.jobexecutor.JobExecutor
          17:03:28,513 DEBUG [ProcessEngineImpl] publishing jBPM ProcessEngine in jndi at java:/ProcessEngine