3 Replies Latest reply on Apr 2, 2010 3:50 AM by jaikiran pai

    JBoss 5.1 Deploy folder

    NIranjan Nanda Apprentice

      Hi,

       

      In JBoss 4.2.3, I was able to change/add deploy locations and instruct JBoss to deploy a particular service/application from a different location. Is it possible in JBoss 5.1?

       

      In JBoss 4.2.3, in jboss-service.xml, there is a service that mentions "deploy" folder which means that JBoss will deploy services/applications from "deploy" folder. I used to add comma separated locations here and JBoss could deploy from those other locations as well.

       

      I want to know if this can be done in JBoss 5.1.

       

      Thanks,

      Niranjan

        • 1. Re: JBoss 5.1 Deploy folder
          Peter Johnson Master

          The deploy folder location in 5.1.0.GA is in the server/xxx/conf/bootstrap/profile.xml file. Look for the "applicationUIRIs" property. Note that unlike 4.2.x and 4.0.x, that this property accepts only directory names (without the trailing slash), you can no longer specify archive file names.

           

          Just add extra <value> entries within the <list> entry.

          • 2. Re: JBoss 5.1 Deploy folder
            NIranjan Nanda Apprentice

            Hi Peter,

             

            Thank you again. But it seems in 5.1 version, it is not as easy to configure this. I just tried to point to a folder which is outside JBoss location (as shown below)

             

            My $JBOSS_HOME points to $HOME/server_instances/instance_1

             

            My configuration folder is present in: server_instances/my-config/app

             

            I tried to configure the URI as follows, but it seems it is not working.

             

            <property name="applicationURIs">
                 <list elementClass="java.net.URI">
                       <value>${jboss.server.home.url}deploy</value>

                       <value>${jboss.server.home.url}deploy/../../../my-config/app</value>
                 </list>

            </property>

             

            With this configuration, JBoss fails to startup. The exception stack trace tells about invalid character in this set up.

             

            I know I am doing something wrong, but not too sure. Could you please help me here?

             

            Thanks,

            Niranjan

            • 3. Re: JBoss 5.1 Deploy folder
              jaikiran pai Master

              NIranjan Nanda wrote:

               


                         <value>${jboss.server.home.url}deploy/../../../my-config/app</value>

              Don't use relative paths. Assuming your $HOME is /home/me then use:

               

              <value>/home/me/server_instances/my-config/app</value>