5 Replies Latest reply on Apr 13, 2010 7:52 AM by Wolfgang Knauf

    Migration pb Jboss4.2.2->5.1 with pictures.war directory under deploy

    Adrien Adrien Apprentice

      Hi

      Im actually migrating from jboss 4.2.2 to jboss 5.1

      Under JBoss4 I have a directory under deploy directory to store image (uploaded).

      So I have in JBOSS 4

      server/..../deploy/picture.war/WEB-INF/web.xml

      -------------------------------------------------------

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
      <web-app >
      </web-app>

       

      server/..../deploy/picture.war/WEB-INF/application.xml

      ----------------------------------------------------------------------------

      <?xml version="1.0" encoding="UTF-8"?>
      <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
      <application >
      </application>

      server/..../deploy/picture.war/

      ------------------------------------------

      all jpeg , accessible via http://myhost/pictures/xx.jpg

      and chat.jar download via http://myhost/pictures/chat.jar  for a chat via a jnlp

       

      With JBOss 5 , i m trying to same thing:

      server/..../deploy/picture.war/WEB-INF/web.xml

      -------------------------------------------------------

      <?xml version="1.0"?>
      <web-app version="2.5"
         xmlns="http://java.sun.com/xml/ns/javaee"
         xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://java.sun.com/xml/ns/javaee http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">
      <web-app >   
      </web-app>
      </web-app>

       

      server/..../deploy/picture.war/WEB-INF/application.xml

      ----------------------------------------------------------------------------

      <?xml version="1.0"  encoding="UTF-8"?>
      <!DOCTYPE web-app PUBLIC "-//Sun Microsystems, Inc.//DTD Web  Application 2.3//EN" "http://java.sun.com/dtd/web-app_2_3.dtd">
      <application >
      </application>

      server/..../deploy/picture.war/WEB-INF/application.xml

      ----------------------------------------------------------------------------

      <?xml version="1.0" encoding="UTF-8"?>
      <application xmlns="http://java.sun.com/xml/ns/javaee"
      xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
      xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
      http://java.sun.com/xml/ns/javaee/application_5.xsd"
      version="5">
      </application>

       

      I 've always an error during deployement of pictures.war, i try to complete web.xml application.xml with module, description etc... but i not found what is the minimal to do it. I obtain always

       

      SAXException: cvc-complex-type.2.4.a: Invalid content was found starting with element 'web-app' or 'application'

       

       

      If Anybody has an idea....Maybe it is not possible under jboss 5.1?

      Thanks a lot