0 Replies Latest reply on Apr 13, 2010 2:45 PM by Frank Bitzer

    ServiceInvoker via RMI - Docs are wrong?!

    Frank Bitzer Newbie

      Hi there,

       

      when you start a JBoss ESB 4.7/4.8 server instance, it creates a Registry using juddi v3. The corresponding entries are present in the JNDI: /juddiv3/UDDIInquiryService, /juddiv3/UDDIPublicationService etc. .

       

      Now I have a remote ServiceInvoker deployed to a second AS. This ServiceInvoker must call some services on the ESB.

      Therefore, I want it to query the Registry using the RMI transport. According to your docs (the Service Guide at http://www.jboss.org/file-access/default/members/jbossesb/freezone/docs/4.8/manuals/html/ServicesGuide.html,  especially in the section "RMI using your own JNDI Registration of the RMI Service"), the settings in the jbossesb-properties.xml for RMI are as follows:

       

      <properties name="registry">
           <property name="org.jboss.soa.esb.registry.implementationClass"                    
      value="org.jboss.internal.soa.esb.services.registry.JAXRRegistryImpl"/>


           <property name="org.jboss.soa.esb.registry.factoryClass"                         
      value="org.apache.ws.scout.registry.ConnectionFactoryImpl"/>


               <property name="org.jboss.soa.esb.registry.queryManagerURI"                    
      value="jnp://localhost:1099/InquiryService?org.apache.juddi.registry.rmi.Inquiry#inquire"/>


               <property name="org.jboss.soa.esb.registry.lifeCycleManagerURI"                    
      value="jnp://localhost:1099/PublishService?org.apache.juddi.registry.rmi.Publish#publish"/>

          
               <property name="org.jboss.soa.esb.registry.user" value="jbossesb"/>
               <property name="org.jboss.soa.esb.registry.password" value="password"/>
              
               <property name="org.jboss.soa.esb.scout.proxy.transportClass"                    
      value="org.apache.ws.scout.transport.RMITransport"/>

      </properties>

      Of course I replaced "localhost" with the hostname of my ESB server. However, in my opinion, this will never work since these settings seem to be only valid to access an "old" juddi v2 registry. It ends up in an javax.naming.NameNotFoundException: InquiryService not bound .

       

      Are there any suggestions how to make the remote ServiceInvoker connect to the juddi v3 registry using RMI?

       

      Thanks,
      Frank