0 Replies Latest reply on Apr 19, 2010 5:28 PM by Ravi Punati

    Application Performance Issues with JBoss 5.1

    Ravi Punati Newbie


           We upgraded our application server from JBoss 4.0.4 GA to JBoss 5.1. We completed the functional testing. While we are doing the performance testing we found the following anamoly. The response times are in the order of a second when the server starts app which is in line with JBoss 4.0.4. After a while (Not able to quantify hours) we see the user response times increase to an order of minute. The subsequent (2nd and 3rd) hits to the the same list views gives us the 4.0.4 comparative performance in the order of seconds. We used treecache in 4.0.4 for some objects and we updated the cache machanism to leverage Jboss 5.1.  We were running Jboss 4.0.4 on Windows 2003 Hyper-V virtual. We attempted to use the same environment for JBoss 5.1. Once we realized the problem we tried the Windows 2003 physical environment. Our configuration is a two node clustered configuration. We eliminated the clustering as the performance was degraded in a single node cluster. The problem is we can't reproduce the problem and we run into this scenario. We attempted to get the system calls using the performance monitor and doesn't yet reveal any thing. We used jconosle and monitored the memory utilization and looks normal. We also did a custom managed swap space of 1.5 times RAM and didn't help either. We use JDK 1.5.



      I am wondering whether any one experience any of these issues. Any insight into what to look for is greatly apprciated.