2 Replies Latest reply on Apr 21, 2010 4:51 PM by Will K

    jmx-console and problems with XML output

    Will K Newbie

      Hello all,


      I'm currently running 5.1.0.GA. My issue is configuring the Mail service from the JMX console.


      I have not made any changes to the "mail-service.xml" file. So in an attempt to configure the mail service (org.jboss.mail.MailService; jboss, service=Mail) from the JMX console, the "Configuration" attribute doesn't display the mail-service configuration correctly.


      From the "mail-service.xml" file:


      <attribute name="Configuration">
            <!-- A test configuration -->
              <!-- Change to your mail server prototocol -->
              <property name="mail.store.protocol" value="pop3"/>
              <property name="mail.transport.protocol" value="smtp"/>


              <!-- Change to the user who will receive mail  -->
              <property name="mail.user" value="nobody"/>


              <!-- Change to the mail server  -->
              <property name="mail.pop3.host" value="pop3.nosuchhost.nosuchdomain.com"/>


              <!-- Change to the SMTP gateway server -->
              <property name="mail.smtp.host" value="smtp.nosuchhost.nosuchdomain.com"/>
              <!-- The mail server port -->
              <property name="mail.smtp.port" value="25"/>
              <!-- Change to the address mail will be from  -->
              <property name="mail.from" value="nobody@nosuchhost.nosuchdomain.com"/>


              <!-- Enable debugging output from the javamail classes -->
              <property name="mail.debug" value="false"/>




      What's displayed on the jmx-console:

      {color:red}<configuration> <!-- Change to your mail server prototocol --> <property name={color}


      Note that when the jmx-console fails to display the full configuration right after the quotes of the configuration. How do I resolve this?


      Thanks for your help.