1 Reply Latest reply on Apr 20, 2010 1:14 PM by Luis Esquivel

    Deployment Missing Dependencies JBoss-service.xml Help JBoss 5.1

    Luis Esquivel Newbie

      Hello,

       

      Can anyone tell me how to correctly add a <depends> attribute in the Jboss-service.xml file?  I am getting the following exception during startup for an MBean that needs to start after the data sources have been created.  I have posted the error and the service configuration below.

       

      Any help will be greatly appreciated.

       

      Thanks.

       

      Error During startup:

      08:03:21,468 ERROR [ProfileServiceBootstrap] Failed to load profile: Summary of
      incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

      DEPLOYMENTS MISSING DEPENDENCIES:
        Deployment "org.xxx:service=h-as400" is missing the following depen
      dencies:
          Dependency "jboss.jdbc:datasource=as400" (should be in state "Create", but i
      s actually in state "** NOT FOUND Depends on 'jboss.jdbc:datasource=as400' **")
        Deployment "org.xxx:service=h-peraflo" is missing the following dep
      endencies:
          Dependency "jboss.jdbc:datasource=peraflo" (should be in state "Create", but
      is actually in state "** NOT FOUND Depends on 'jboss.jdbc:datasource=peraflo' *
      *")

      DEPLOYMENTS IN ERROR:
        Deployment "jboss.jdbc:datasource=peraflo" is in error due to the following re
      ason(s): ** NOT FOUND Depends on 'jboss.jdbc:datasource=peraflo' **
        Deployment "jboss.jdbc:datasource=as400" is in error due to the following reas
      on(s): ** NOT FOUND Depends on 'jboss.jdbc:datasource=as400' **

       

      In jboss-service.xml I have 2 MBeans declared as shown below:

       

      <mbean code="org.xxx.service.HSessionFactory"
            name="org.xxx:service=hibernate-peraflo">
            <attribute name="ConfigFileLocation">c:/j2eeapps/lib/h-peraflo.cfg.xml</attribute>
            <depends>jboss.jdbc:datasource=peraflo</depends>
         </mbean>
        
         <mbean code="org.xxx.service.HSessionFactory"
            name="org.xxx:service=hibernate-as400">
            <attribute name="ConfigFileLocation">c:/j2eeapps/lib/h-as400.cfg.xml</attribute>     
            <depends>jboss.jdbc:datasource=as400</depends>
         </mbean>

       

      The error above happens when I add the <depends> in the service.xml file.

       

      Thanks.