6 Replies Latest reply on Apr 27, 2010 11:46 AM by Ian Henderson

    JOPR 2.3.1 not registering agent

    Ian Henderson Newbie

      Hi,

       

      Any pointers or assistance with the following would be much appreciated...

       

      I have two instances of JOPR 2.3.1 set-up to monitor a JBossESB (running via Service-Wrapper) and JBossAS 4.2.3.GA (running from console) installations.  All implemented on Windows 2003 servers.

       

      In both cases, the RHQ-Agent (running on console), running on the JBossESB/JBossAS server is not registernig with it's respective JOPR agent.  No firewall exists between the JBossESb and it's JOPR server, while all ports are open on a firewall between the other server/client pair.

       

      What I have seen are a load of exceptions in the Agent logs (see attached log file).  I've ignoring those resulting from the PostgreSQL discovery exceptions when they appear...

       

      The one exception that concerns me is the following:

       

      2010-04-21 11:35:14,474 WARN  [ResourceContainer.invoker.daemon-1] (org.rhq.plugins.jbossas.JBossASServerComponent)- Could not establish connection to the JBoss AS instance

       

      ...where it's attempting to connect to 'jnp://127.0.0.1:1099'.  The AS is running with a options '-b 10.170.22.15', so I would not expect a localhost connect to work.  Is this what's causing my problem though?  Okay, the agent can't connect to the AS, but how would this explain why it's not visible on JOPR.

       

      From the RHQ console, 'ping', 'rediscover' and 'register 30 regenerate' all seem to work fine with nothing untoward benig displayed or logged.

       

      What the heck am I missing??? (IQ points and good-looks aside)

       

      What debug options are there for monitoring/checking the comms between RHQ Agent and JOPR Server?

       

      Thanks in advance for any assistance offered...

       

      Regards

      Ian Henderson

        • 1. Re: JOPR 2.3.1 not registering agent
          Ian Springer Master

          Hi,

           

          Keep in mind the RHQ Server doesn't talk to ant managed AS instances directly. The RHQ Agent talks to the AS instances (via JMX over JNP) that are running on the same machine as itself. The Agent then reports back to the RHQ Server.

           

          If you started your AS with -b 192.168.11.22, then you'll need to change the JNP URL the Agent uses to connect to it to jnp://192.168.11.22:1099. You can do this by going to the JBoss AS Resource's Inventory>Connection tab in the JON GUI and editing its connection properties. Update the value of the JNP URL connection property and then save the connection properties (make sure the Agent and AS instance are both running first. Then wait a couple minutes, and the AS Resource should turn green in RHQ.

          1 of 1 people found this helpful
          • 2. Re: JOPR 2.3.1 not registering agent
            Ian Henderson Newbie

            Thanks Ian...

             

            I had a similar problem with JMX on a test installation, albeit related to login credentials in that case, so I was execpting to do something similar to

            change the URL.

             

            The problem I have in this case is that the RHQ Agent is not being  registered on the JOPR Server... i.e it's not showing in the  Auto-Detection Queue.

             

            What you're saying though does assist... it suggests the exception I'm seeing in the Agent log is related to RHQ Agent talking with the JBossAS, and not RHQ Agent to JOPR Server.

             

            Previous attempts to link RHQ Agents (monitoring JBossESB and IIS servers) with JOPR Servers have all worked fine... but in two cases, I'm getting absolutely nothing on the JOPR Server Web Console.

            • 3. Re: JOPR 2.3.1 not registering agent
              Ian Springer Master

              If your not seeing the Agent get registere don the Server, then there is most likely something not configured right in the Agent to Server comm settings. The first thing I'd try is restarting the Agent fresh using:

               

              rhq-agent.bat -lu

               

              This will re-prompt you for the Agent connection info (Agent name, Agent IP/port, and Server IP/port). Try to use the same Agent name you used previously. For the IPs and ports, make sure the values are correct. The Agent will then try to re-register with the Server. Watch the Server and Agent log files to see if it connects and registers successfully. If not, paste the errors from the logs here. If the Agent does register successfully, you should see the Platform appear in the autodiscovery portlet on the RHQ Dashboard after a few minutes.

               

              If it does not register successfully, another thing to check is that the Server address is correct under Administration>HA>Servers in the RHQ GUI - make sure the address set there is valid and reachable from all Agents.

              1 of 1 people found this helpful
              • 4. Re: JOPR 2.3.1 not registering agent
                Ian Henderson Newbie

                Thanks again Ian...

                 

                I'd been through the configuration a number of times, doing exactly what you've suggested... and double checking every step...

                 

                The one thing I had not done was check the JOPR Server logs... so thanks for the prompt on that one...

                 

                Looking at the logs, I saw some very obvious Seam access oriented errors... every time the

                 

                Logging out of JOPR with my login and logging back in as rhqadmin stopped the errors... AND... all of a sudden I can see the RHQ Agents...

                 

                Checking my login I realised I'd not added the correct roles (i.e. Super User)... it would seem that without this, the Auto-Discovery does not work correctly but offers no visble clue to the user... the logs take a heck of a battering though...

                 

                I'm not convinced this is an error or bug, but it's certainly an opportunity for enhancement...

                 

                Many thanks for your assistance...

                • 5. Re: JOPR 2.3.1 not registering agent
                  mazz Master

                  FYI: In order to view the auto-discovery queue and import resources, the user must have the global INVENTORY permission at minimum.

                   

                  http://rhq-project.org/display/JOPR2/Security+Model#SecurityModel-GlobalPermissions

                   

                  "Inventory - Allows the user to perform any task on any resource. Having a role with this permission grants the user to add, delete, configure, control and modify any resource, regardless of what other roles and associated groups of resources the user has been given access to. This is also the permission required in order to be able to import new resources into inventory."

                  • 6. Re: JOPR 2.3.1 not registering agent
                    Ian Henderson Newbie

                    Thanks John... for providing the answer to my next question... :-)