5 Replies Latest reply on Apr 23, 2010 6:36 AM by Sukla Nag

    Problem with deployment of process design

    Sukla Nag Newbie

      I have downloaded eclipse gallelio & jbpm installer,  jbpm-4.3.zip. I have unzipped the jbpm in d:\jbpm directory & in Eclipse I have installed the jbpm using local site & directing the runtime locatiion to the d:\jbpm directory.& server deployer is showing as /jbpm-console/upload

       

      I have created a process project & have created a process definition using the gui & source both. When I tried to deploy, connection to server is tested successfully , but the process definition is not getting deployed, it says 'An unexpected exception caused the deployment to fail"

       

      Cpould any one tell me the problem ?

       

      Thanks in advance

        • 1. Re: Problem with deployment of process design
          HuiSheng Xu Master

          Hi Sukla,

            There is no deploy menu in the GPD for jBPM 4.3.

           

             It seems you are using a jbpm 3 plugin to deploy jbpm4.  But they can't worked togethor.  You should use GPD in jBPM 4.3 to design process definition for jBPM 4.3.

          • 2. Re: Problem with deployment of process design
            Sukla Nag Newbie

            Hi Huisheng

             

            Thanks a lot for the reply. You are right that I have used jbpm-installer-3.2.6.SP1 installer for installing all war files in the jboss4.2.2 & in eclipse platform I have pointed the JBOSS JBPM run time version to the directory of inzipped file of jbpm-4.3.zip. So it may be creating deployment problem. I have also tried this way - I ctreated an archive file for deplyment from the deplyment menu of gpd.xml & have tried to upload it from the process deployment of the jbpm-console menu. I got the error

             

            Error deploying process: An exception of type  "org.hibernate.exception.SQLGrammarException" was thrown.  The message  is: could not retrieve generated id after insert:  [org.jbpm.graph.def.ProcessDefinition]

             

            But when I tried to point the Jbpm3.2.6 directory to the run time version of JBOSS JBPM in eclipse, it did not accept saying not valid BPM installation.

             

            Could you please tell me the exact installation procedure by which I can run the jbpm-console web application & can upload the process definition file (archived) created by process designer in eclipse environment ( or some other environment) using some eclipse plug in or whatever required in other environment ( may be stand alone).

             

            I would appreciate very much if you kindly let me know.

             

            Thanks once again.

            • 3. Re: Problem with deployment of process design
              HuiSheng Xu Master

              Hi Sukla,

                I am sorry, I am not familiar with jBPM-3.x.  If you want to use jBPM-4.3, there is the User guide you could followed.

               

              http://docs.jboss.com/jbpm/v4/userguide/html_single/

               

                Or maybe you could ask in the user forum, this is the developer forum, so here is few people talking about how to use jBPM.

               

              cheers.

              • 4. Re: Problem with deployment of process design
                Sukla Nag Newbie

                Hi Huisheng

                 

                Thanks a lot for the help. May be that will solve my problem. I think my installation was not correct.

                • 5. Re: Problem with deployment of process design
                  Sukla Nag Newbie

                  Hi Huisheng

                   

                  Thanks for the help you gave in mentioning the user's guide, I have now deploye the entrire jbpm4.3 which installed jboss, eclipse all in the same direvctory of jbpm.

                   

                  But now when I am trying to design a process, I need a project to be created, in version 3 there was a bpmn project which I was able to create, but now there is only bpm process definition menu. When I am trying to ctreate a new bpmn process definition, it is asking for a existing project. I craeted a dynamic web project & then tried to create a process definition, I am having two problems

                   

                  1. The xml file created is not accepted saying no dtd definition, I checked one sample jpdl file, mine is same, but it is showing errors

                  2. Now there is no depoment / creation of process archive menu in gpd. SO how do I create a process archive or deploy now ?

                   

                  Also if I changr the source file, the diagram does not change.

                   

                  Could you please suggest something ?

                   

                  Thanks one again