2 Replies Latest reply on Apr 29, 2010 8:49 PM by Earnest Dyke

    jbpm 3.2.2 on JBoss 5.1

    Earnest Dyke Novice

      Greetings all,

       

      I am trying to install jbpm 3.2.2 onto a JBoss 5.1 server without success. I created a datasource and copied jbpm-console.war to my deploy directory but when it tries to deploy, I see the following error in the log:

       

      java.lang.NoClassDefFoundError: edu/emory/mathcs/backport/java/util/concurrent/ConcurrentMap

       

      It appears that the Backport jar is not available. So I added backport-util-concurrent-3.0.jar from JBoss 4.2 and restarted. Now I see this error in the log:

       

      java.lang.ClassCastException: com.sun.faces.application.ApplicationAssociate cannot be cast to com.sun.faces.application.ApplicationAssociate

       

      Before I spend much more time banging my head against the wall: will jbpm 3.2.2 run under JBoss 5.1? If so, are there instructions on how to?

       

      Thanks in advance for any and all pertinent advice.

       

      Earnie!

        • 1. Re: jbpm 3.2.2 on JBoss 5.1
          Sebastian Schneider Master

          I have no clue but I have a question and a proposal. Why are you using jBPM 3.2.2 although jBPM 3.2.8 is the most recent stable version? Maybe you should switch to using jBPM 3.2.8 to try this. Chances could be higher finding other people running or trying to run jBPM 3.2.28 on JBoss 5.1 than that there are chances to find other people using 3.2.2.

           

          Just my 2 cents.

          • 2. Re: jbpm 3.2.2 on JBoss 5.1
            Earnest Dyke Novice

            Thanks for your reply. I am using jbmp 3.2.2 because that is what is bundled with Seam 2.2. Since I first posted my original message I have installed jbpm 4.3 and am working through that now. I won't be able to use the Seam annotations, from what I have read, but I will have a working jbpm on JBoss 5.1.

             

            Thanks again.

             

            Earnie!