8 Replies Latest reply on Feb 17, 2011 6:22 AM by Samuel Tauil

    Slow Boot Up - JBoss AS  5.1.0.GA

    Aaron Kirley Newbie

      Does anybody know how to optimize the boot up speed for JBoss AS 5.1.0.GA, it seems to hang for about 25 seconds between the [LogNotificationListener] and the [Ejb3DependenciesDeployer].  I'm wondering if there is some way to fix this issue in my development environment where I find myself restarting the servier frequently (i'm not even using EJB's).

       

      11:08:09,186 INFO  [LogNotificationListener] Adding notification listener for logging mbean "jboss.system:service=Logging,type=Log4jService" to server org.jboss.mx.server.MBeanServerImpl@22e85825[ defaultDomain='jboss' ]
      11:08:33,615 INFO  [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1696642166{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
      11:08:33,615 INFO  [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1696642166{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
      11:08:33,615 INFO  [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1696642166{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
      11:08:33,615 INFO  [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1696642166{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
      11:08:36,097 INFO  [JMXConnectorServerService] JMX Connector server: service:jmx:rmi://localhost/jndi/rmi://localhost:1090/jmxconnector
      11:08:36,191 INFO  [MailService] Mail Service bound to java:/Mail
      


      Thanks in advance for your help...

        • 1. Re: Slow Boot Up - JBoss AS  5.1.0.GA
          jaikiran pai Master

          Slow bootup time is a known issue in AS 5.1.0.

           

          it seems to hang for about 25 seconds between the [LogNotificationListener] and the [Ejb3DependenciesDeployer]

          Actually, it doesn't hang. It gives you an impression that it hangs because there's no INFO level logging at that time. What time does it take for your clean server to startup? And what OS do you have and what machine configurations?

          • 2. Re: Slow Boot Up - JBoss AS  5.1.0.GA
            Aaron Kirley Newbie

            I am running JBoss AS on Windows 7, 64bit with 8GB ram.

             

            10:26:09,872 INFO  [ServerInfo] Java version: 1.5.0_22,Sun Microsystems Inc.
            10:26:09,872 INFO  [ServerInfo] Java Runtime: Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_22-b03)
            10:26:09,872 INFO  [ServerInfo] Java VM: Java HotSpot(TM) 64-Bit Server VM 1.5.0_22-b03,Sun Microsystems Inc.
            10:26:09,872 INFO  [ServerInfo] OS-System: Windows 7 6.1,amd64
            


            and these are my VM arguments

             

            -Dprogram.name="JBossTools: JBoss 5.1 Runtime" 
            -Xms512m -Xmx1024m -XX:MaxPermSize=256m 
            -Dsun.rmi.dgc.client.gcInterval=3600000 
            -Dsun.rmi.dgc.server.gcInterval=3600000 
            -Djava.endorsed.dirs="C:\Development\JBoss\jboss-5.1.0.GA\lib\endorsed" 
            -Djavax.net.ssl.trustStore="C:\Development\JBoss\jboss-5.1.0.GA\server\default\conf\dev.truststore" 
            -Djavax.net.ssl.trustStorePassword=password
            

             

             

            A clean boot time:"Started in 35s:631ms" but typically is see closer to 1 minute.  Here is a snippit from the clean boot log:

             

             

            10:26:19,314 INFO [LogNotificationListener] Adding notification listener for logging mbean "jboss.system:service=Logging,type=Log4jService" to server org.jboss.mx.server.MBeanServerImpl@626bd9e0[ defaultDomain='jboss' ]
            10:26:30,380 INFO [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1701597359{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
            10:26:30,380 INFO [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1701597359{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
            10:26:30,380 INFO [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1701597359{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
            10:26:30,380 INFO [Ejb3DependenciesDeployer] Encountered deployment AbstractVFSDeploymentContext@1701597359{vfsfile:/C:/Development/JBoss/jboss-5.1.0.GA/server/default/deploy/profileservice-secured.jar/}
            
            
            • 3. Re: Slow Boot Up - JBoss AS  5.1.0.GA
              Peter Johnson Master

              You didn't mention what processor you have, but I have the same configuration with a quad-core processor @2.4Ghz and my start times are also around 30-35 seconds. So the times you mention are not out of line with what others are experiencing. Of course, if I have apps deployed it takes longer - I was recently working with Riftsaw and the boot times were 90 seconds or longer.

               

              Just for the record, a clean 4.2.3 starts in 10-15 seconds.

              1 of 1 people found this helpful
              • 4. Re: Slow Boot Up - JBoss AS  5.1.0.GA
                jaikiran pai Master

                Aaron Kirley wrote:

                 


                 

                A clean boot time:"Started in 35s:631ms"


                That's kind of "normal" for AS 5.1.0

                 

                Aaron Kirley wrote:

                 

                but typically is see closer to 1 minute. 

                *Maybe* you are affected by these:

                 

                https://jira.jboss.org/jira/browse/JBCL-117

                 

                https://jira.jboss.org/jira/browse/JBCL-118

                • 5. Re: Slow Boot Up - JBoss AS  5.1.0.GA
                  Aaron Kirley Newbie

                  Peter - I have a 3.1 GHz Dual Core processor so i guess my startup time is in line with what's "normal".

                   

                  Jaikiran - I checked out the two jira's and i tried booting up with both of the patched jar files (jboss-classloader.jar and jboss-vfs.jar) but the boot time didn't improve.  Unless there is more to installing the patch than swapping out the old jars with the new, then I guess we can assume this isn't a DNS issue.

                   

                  I tried to tinker with the logging levels but I still can't see what is causing the delay between [LogNotificationListener] and [Ejb3DependenciesDeployer].

                  • 6. Re: Slow Boot Up - JBoss AS  5.1.0.GA
                    Zemian Deng Apprentice

                    If you are not using EJB, then why not try the "web" server configuration? It starts 3-4 times faster than the "default". If you are using even less than those services provided, try the "minimal", it's pretty bare and quick.

                     

                    /Z

                    • 7. Re: Slow Boot Up - JBoss AS  5.1.0.GA
                      Aaron Kirley Newbie

                      Thank you, that fixed the slow boot up issue for me.

                      • 8. Slow Boot Up - JBoss AS  5.1.0.GA
                        Samuel Tauil Newbie

                        Aaron and what about the patch? resolved or you just switch the server profile as workaround?