2 Replies Latest reply on Dec 24, 2010 10:33 AM by Khurram Majeed

    Problem using "clustered" JMS Queues with JBoss 5.1.0.GA

    Felix Reuthlinger Newbie

      Hi,

       

      I've tried using the JBoss JMS clustered queue for delivering messages in a distributed application cluster. The Problem here is, that some times I start up all cluster nodes (with a almost unmodified "all"-environment) and run the application, but the messages posted at one node will not be pulled to any of the other nodes.

       

      I have 2 to 5 nodes running the application, the application is divided in two ear files, one with the driver-application that uses ejb-clustering to access the other 1 to 4 nodes which run the service application. To publish some statistic values I use a clustered queue that is deployed at the "deploy" folder on each node. Everything deploys normally without any warn/errors. The application runs without any problem. It's just the one thing: messages will not be pulled to any other node and especially not the one node that should receive all the messages and make some calculations with the statistic values.

       

      Just some times (I don't know how to rebuild the case) it simply works, messages will be pulled. But all the other times I shutdown and startup all nodes or each node alone, this will simply not work.

       

      Here is the config for the queue:

       

      <?xml version="1.0" encoding="UTF-8"?>

      <server>

         <mbean code="org.jboss.jms.server.destination.QueueService"
            name="stockSimulation.messaging:service=Queue,name=ClusterStatisticsQueue"
            xmbean-dd="xmdesc/Queue-xmbean.xml">
            <depends optional-attribute-name="ServerPeer">jboss.messaging:service=ServerPeer</depends>
            <depends>jboss.messaging:service=PostOffice</depends>
            <attribute name="Clustered">true</attribute>
         </mbean>
      </server>

       

      I also tried to fix the problem using the latest JBM core 1.4.6.GA (like it is discribed in http://community.jboss.org/message/517783#517783), but this problem still exists. Maybe there is still a problem with the message pulling from one to the other node?

       

      Any suggestions would help!

        • 1. Re: Problem using "clustered" JMS Queues with JBoss 5.1.0.GA
          Felix Reuthlinger Newbie

          Ok I think I found the problem: copying all the config file from the newer JBM core was not a good idea. These had the PostOffice set to non-clustered. Changing this like at the all config before solved the problem, nor messages are pulled from one the other node.

          • 2. Re: Problem using "clustered" JMS Queues with JBoss 5.1.0.GA
            Khurram Majeed Newbie

            Hey Felix

             

            I have setup a JBoss 5.0 Cluster  with JMS Topic deployed in  deploy-hasingleton, my first instance starts  successfully but when  second node starts i am getting this exception,  one thing weird i have  noticed is that sometimes second node starts  smoothly, i dont get this  exception - i had to retry 4-5 times to start  the server. Can anyone  help me in this?

             

            Stacktrace:

             

            javax.jms.InvalidDestinationException: No such destination: JBossTopic[MyMessage] has it been deployed?
                 at org.jboss.jms.server.endpoint.ServerSessionEndpoint.createConsumerDelegateInternal(ServerSessionEndpoint.java:1838)
                 at org.jboss.jms.server.endpoint.ServerSessionEndpoint.createConsumerDelegate(ServerSessionEndpoint.java:252)
                   at    org.jboss.jms.server.endpoint.advised.SessionAdvised.org$jboss$jms$server$endpoint$advised$SessionAdvised$createConsumerDelegate$aop(SessionAdvised.java:94)
                 at

             

            Khurram