Yup - I agree with your abbreviations - the article you are proposing should work well in the component requirements area.
as for turning it all on/off - I'm not sure about that - I'll need to think on it.
Ok. then I will wait for some more feedback and convert this thread to article
about turning off - I'm afraid it will not be possible to design all the components using strict semantic approach. We will probably need some exceptions as it was discussed in some threaads about tabs and other deisgn threads. So I believe that turning off will even broke such components :/ Anyway it's separate discussion.
After looking second time to proposal and to existent classes I think need also to divide part-subpart from state and utility modificators.
so the result:
rf-<component name abbreviation>[-[<component part abbreviation>][some subpart abbreviation][-<state abbreviation>][some utility modificator abbreviation]]
And the last stlye in examples above will be:
- rf-edt-r-s - rich class for selected row(tr) of extendedDataTable component
- and one more rf-cb-i-h - rich class for combobox iteme in hovered state.